Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Ubuntu not showing up as a Boot option in BIOS

  1. #1
    Join Date
    Sep 2023
    Beans
    4

    Ubuntu not showing up as a Boot option in BIOS

    Hey guys,
    so I recently installed Ubuntu 23.04 on my HP Omen 15 as a dual boot with Windows 10 and my BIOS doesn't seem to recognize Ubuntu as a viable boot options. However when I press F9 before startup and access the HP boot override it is listed there. Is there any way to fix this? I have tried updating grub already.

  2. #2
    Join Date
    May 2008
    Beans
    4,137
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Ubuntu not showing up as a Boot option in BIOS

    Can you successfully boot Ubuntu via the dedicated boot key F9?

  3. #3
    Join Date
    Sep 2023
    Beans
    4

    Re: Ubuntu not showing up as a Boot option in BIOS

    Yes I can normally boot into grub using F9

  4. #4
    Join Date
    May 2008
    Beans
    4,137
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Ubuntu not showing up as a Boot option in BIOS

    I'm struggling to fully understand what you want to accomplish.
    As Ubuntu appears in your PC boot menu via F9, it is, therefore, recognised by the HP UEFI settings.

    Do you want Ubuntu to be the priority boot and allow grub to also control booting Windows?

  5. #5
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 24.04 Noble Numbat

    Re: Ubuntu not showing up as a Boot option in BIOS

    See Boot-Repair in my signature below and follow the instructions there to run the Boot-Info-Script.

    Do not run the default repair just yet but simply copy back here the pastebin link you get which will show us a lot more about your system.

  6. #6
    Join Date
    Sep 2023
    Beans
    4

    Re: Ubuntu not showing up as a Boot option in BIOS

    Right, sorry for taking so long I had to deal with irl stuff, here's the pastebin : https://paste.ubuntu.com/p/kXgVqWfzW7/

  7. #7
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ubuntu not showing up as a Boot option in BIOS

    HP seems to be the only vendor to not recognize boot order changes with efibootmgr.
    Grub install uses efibootmgr to change boot order.

    You can see boot order here, Same as shown starting at line 63 in report.:
    sudo efibootmgr -v

    Most with HP find they can change boot order in UEFI settings (not UEFI boot menu). There should be a boot tab in the settings menu.
    HP - escape + F9 for UEFI boot menu, F10 for UEFI/bios settings
    One of many HP users:
    hp 250 g3 Change boot order in UEFI settings
    https://ubuntuforums.org/showthread.php?t=2467077

    Note that Windows updates may reset boot order or UEFI settings back to defaults. It may also update Windows settings to turn on fast startup & then grub will not boot Windows.
    Both Windows & Ubuntu/grub on major updates reset boot order. But HP is exception.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #8
    Join Date
    Sep 2023
    Beans
    4

    Re: Ubuntu not showing up as a Boot option in BIOS

    Right, I can't do that, is there anything else I can try or am I doomed to spamming f9 to start Ubuntu?

  9. #9
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ubuntu not showing up as a Boot option in BIOS

    Some with HP posted it was under a sub-menu or they had to turn off Secure Boot.
    You may need to review manual from HP for your model.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  10. #10
    Join Date
    May 2008
    Beans
    4,137
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Ubuntu not showing up as a Boot option in BIOS

    Quote Originally Posted by p1k1p1k1 View Post
    Right, I can't do that, is there anything else I can try or am I doomed to spamming f9 to start Ubuntu?
    Not sure yet, let's investigate further.

    Can you access your UEFI settings via F10
    Disable TPM
    Disable Secure Boot
    Disable Legacy Support
    System Configuration > Boot Options > OS Boot Manager
    Any options under OS Boot Manager?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •