Results 1 to 2 of 2

Thread: Problem with wireguard and Ubuntu server

  1. #1
    Join Date
    Sep 2023

    Problem with wireguard and Ubuntu server

    I have a VPS Ubuntu server on AWS on which I run a Wireguard client, while my Wireguard server is in my home router with Open WRT firmware. The server works correctly because I tried to connect remotely with various clients including Android, Windows and Kali and the internet connection was correctly routed to my home router, thus allowing me to use its public IP even from remote clients, running a speedtest I see that on these clients the upload and download speed is 20 mbps and that's ok for me. On the Ubuntu VPS, however, something is wrong, because Wireguard doesn't work well, traffic isn't routed correctly on wireguard, even if ssh from another client connected to the same VPN works, if I run wget to see my public IP I can see that of the home router but if for example I run speedtest-cli as download speed I get 0 mbit/s while in upload 6 mbit/s same problem if I run an apt-get update I get 0% [Waiting for headers]. I think it's a routing problem that unfortunately I don't know how to solve, I searched on the web but I didn't find anyone with a similar problem. This is the configuration as a Wireguard client on the Ubuntu Server VPS:
    Address =
    PrivateKey = (My private key)
    DNS =
    ListenPort = 51820
    PublicKey = (router wireguard Public Key)
    AllowedIPs =
    Endpoint = (Public IP homenetwork):51820

    Thanks, any help is welcome.
    Last edited by viciud; September 16th, 2023 at 06:49 PM.

  2. #2
    Join Date
    Aug 2016
    Xubuntu Development Release

    Re: Problem with wireguard and Ubuntu server

    Not sure i can help, but you can watch what's happening with:
    sudo watch wg show
    Looks like to me a routeing problem as well,(Mine allowed ips: ::/0, )there is a GUI browser based to help with that:
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts