Results 1 to 4 of 4

Thread: super tiny fonts with an xorg.conf installed.

  1. #1
    Join Date
    Jan 2014
    Beans
    35

    super tiny fonts with an xorg.conf installed.

    My gtk at qt fonts will suddenly become small when I install an xorg.conf file with nvidia-settings. I can revert it by removing the file. Not really sure what the problem could be. Operating System: Ubuntu Kylin 22.04 KDE Plasma Version: 5.24.7 KDE Frameworks Version: 5.92.0 Qt Version: 5.15.3 Kernel Version: 6.2.0-32-generic (64-bit) Graphics Platform: X11 Processors: 12 × AMD Ryzen 5 2600X Six-Core Processor Memory: 47.0 GiB of RAM Graphics Processor: NVIDIA GeForce GTX 1080/PCIe/SSE2

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: super tiny fonts with an xorg.conf installed.

    Can't you just adjust the system font size in settings?
    It also would not hurt to show your xorg.conf file
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #3
    Join Date
    Jan 2014
    Beans
    35

    Re: super tiny fonts with an xorg.conf installed.

    My problem is that I have multiple desktop envrionments running different things all on the same desktop, so there are many font configurations involved. KDE, xfce, gtk, qt. After ap plying this xorg.conf file, the issue happens.

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 510.47.03
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "SAMSUNG"
        HorizSync       15.0 - 81.0
        VertRefresh     24.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "NVIDIA GeForce GTX 1080"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-7"
        Option         "metamodes" "DP-5: 1920x1080 +1920+1080, HDMI-0: nvidia-auto-select +561+312, DP-1: 1920x1080 +0+1080, DP-3: nvidia-auto-select +1920+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Last edited by QIII; September 14th, 2023 at 10:27 PM. Reason: code tags added

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: super tiny fonts with an xorg.conf installed.

    I found why, and please used code tags for any terminal or text.conf files.
    You have nothing here:
    Code:
    Section "Files"
    EndSection
    My suggestion would be like this example:
    Code:
    Section "Files"
            FontPath     "/usr/local/share/fonts/bitstream-vera/"
            FontPath     "/usr/local/share/fonts/cyrillic/"
            FontPath     "/usr/local/share/fonts/webfonts/"
            FontPath     "/usr/local/share/fonts/dejavu/"
            FontPath     "/usr/local/share/fonts/terminus-font/"
    EndSection
    Edit the path as needed for your use, and font names to your liking.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •