Results 1 to 8 of 8

Thread: Can't use apt since it shows an error

  1. #1
    Join Date
    Sep 2023
    Beans
    4

    Can't use apt since it shows an error

    Hi there,
    I tried apt clean, --reinstall the packages, autoremove, and installing the packages separately.
    Can someone help me please?
    The error is in the screenshot.


    Thanks!
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2011
    Location
    52.5° N 6.4° E
    Beans
    6,832
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Can't use apt since it shows an error

    There are two files that are provided by two different packages on your system, which is an error. One comes from both libgstreamer-plugins-bad and libgstreamer-plugins-good. It only belongs in the latter. Those packages, in particular the former, are not essential. The other conflicting file comes from two different versions of libsgutils. Only one of those is present in currently supported Ubuntu releases. It appears you've got some packages on your system that don't belong there.

    Can you tell us which version of Ubuntu is on your computer? And could you simply copy the terminal output as text to your forum post and enclose it in [code]code tags (like this)[/code]? That's easier to read and allows me to copy it from your post and paste it somewhere else. And saves you from having to deal with screenshots and attachments.

  3. #3
    Join Date
    Sep 2023
    Beans
    4

    Re: Can't use apt since it shows an error

    Okay, of course.
    There is another problem: I installed the latest Ubuntu Lobster, but now somehow neofetch thinks it is Kali Linux 2023.2

  4. #4
    Join Date
    Sep 2023
    Beans
    4

    Re: Can't use apt since it shows an error

    I just realized that a lot of pictograms are missing from my system, for example the previous and next icons when browsing apps, or the little icons in settings.

  5. #5
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    4,965

    Re: Can't use apt since it shows an error

    Quote Originally Posted by matefon View Post
    now somehow neofetch thinks it is Kali Linux 2023.2
    The most common cause is installing katoolin packages.
    Regardless of the cause, Ubuntu to Kali is a one-way trip.
    It cannot be undone. Kali makes too many changes.
    Time to reinstall.

  6. #6
    Join Date
    Sep 2023
    Beans
    4

    Re: Can't use apt since it shows an error

    That is unfortunate.
    Can I reinstall the system without losing my personal data?

  7. #7
    Join Date
    Mar 2010
    Location
    /home
    Beans
    9,467
    Distro
    Xubuntu

    Re: Can't use apt since it shows an error

    Do you have your personal data on a separate /home partition?

    If yes, then you can reinstall but making sure to point the installer to just the /root partition.

    If not, then backup everything important and then reinstall.

    Actually, you should backup everything anyway just in case.

  8. #8
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Can't use apt since it shows an error

    Quote Originally Posted by matefon View Post
    That is unfortunate.
    Can I reinstall the system without losing my personal data?
    Sure you can!

    Backup everything in your /home to an external disk or a separate partition, which you must always do anyway (you do that don't you?) then reinstall the OS and lastly restore your files.

    Backing up personal files is essential practice for any computer user; installing or reinstalling the OS is a few minutes job but recovering personal files without backups is very different and once lost they may be lost forever.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •