Results 1 to 3 of 3

Thread: How to disable on board bluetooth on RPI4 and not the bluetooth usb

  1. #1
    Join Date
    Aug 2023
    Beans
    2

    Post How to disable on board bluetooth on RPI4 and not the bluetooth usb

    Hello,
    I searched the internet for a solution, but couldn't find a suitable one. I blocked the UART (ttyAMA0) and tried other suggestions, both the on board and the usb BT are disabled then. How can I disable the on board BT and have the usb BT enabled. I use a metal box and the bluetooth is weak.
    Thanks in advance
    Kees

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: How to disable on board bluetooth on RPI4 and not the bluetooth usb

    While using the RPI4, can you show us this please:
    Code:
    less /boot/overlays/README
    I need to see that file
    and also show:
    Code:
    rfkill list all
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #3
    Join Date
    Aug 2023
    Beans
    2

    Re: How to disable on board bluetooth on RPI4 and not the bluetooth usb

    Hello,
    kees@kees-desktop:~$ sudo su
    [sudo] password for kees:
    root@kees-desktop:/home/kees# less /boot/overlays/README
    /boot/overlays/README: No such file or directory
    root@kees-desktop:/home/kees# rfkill list all
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: hci1: Bluetooth
    Soft blocked: no
    Hard blocked: no

    When I (soft) block hci1 hci0 doesnt work eather.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •