Results 1 to 9 of 9

Thread: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

  1. #1
    Join Date
    May 2010
    Location
    Northern California
    Beans
    77
    Distro
    Ubuntu 18.04 Bionic Beaver

    Thumbs down kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    Tried to install the new stable release 6.5.0-generic kernel from the Mainline PPA and got met with the post title error message.

    Have installed all of the previous 6.5-rc kernels prior to this with no problems.

    Running Ubuntu 22.04.3 distro on a Zen 4 7950X host which uses libc6 2.35.

    Currently on the 6.5-rc7 kernel.

    What changed?

  2. #2
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,515
    Distro
    Ubuntu Development Release

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    The mainline kernel is compiled from the development version of Ubuntu, or 23.10. In the last week it would have gone to a newer version of libc6 (newer compiler, actually), causing issues with older versions of Ubuntu trying to install that kernel. I am still using 20.04, and have these issues for years:

    Code:
    Setting up linux-headers-6.5.0-060500 (6.5.0-060500.202308271831) ...
    dpkg: dependency problems prevent configuration of linux-headers-6.5.0-060500-generic:
     linux-headers-6.5.0-060500-generic depends on libc6 (>= 2.38); however:
      Version of libc6:amd64 on system is 2.31-0ubuntu9.9.
     linux-headers-6.5.0-060500-generic depends on libssl3 (>= 3.0.0); however:
      Package libssl3 is not installed.
    I have to compile the kernel myself to be able to install it.
    See also the old related bug report, from last time this happened.
    Last edited by Doug S; August 28th, 2023 at 03:08 PM.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  3. #3
    Join Date
    Jul 2008
    Beans
    6
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    Can confirm #mainline and even 6.4.x now seems to exhibit the same issue:

    Code:
    Setting up linux-modules-6.4.13-060413-generic (6.4.13-060413.202308301431) ...
    Setting up linux-headers-6.4.13-060413 (6.4.13-060413.202308301431) ...
    dpkg: dependency problems prevent configuration of linux-headers-6.4.13-060413-generic:
     linux-headers-6.4.13-060413-generic depends on libc6 (>= 2.38); however:
      Version of libc6:amd64 on system is 2.35-0ubuntu3.1.
    
    dpkg: error processing package linux-headers-6.4.13-060413-generic (--install):
     dependency problems - leaving unconfigured

  4. #4
    Join Date
    Sep 2023
    Beans
    1

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    I tried Jammy LTS Mainline Kernels and it works for me. Alternatively you can go to the Jammy LTS Mainline repo, follow their README and build the kernel with less than 5 commands.

    For Jammy LTS, you can use the follow command,
    Code:
    # Add Jammy LTS repo
    sudo add-apt-repository ppa:tuxinvader/jammy-mainline
    # Install Kernel 6.5.2
    sudo apt install linux-modules-6.5.2-060502-generic linux-headers-6.5.2-060502-generic linux-image-unsigned-6.5.2-060502-generic
    The second command may not work for you because the repo only keep the latest 2 release, due to the size limit. Please check the repo for the latest release and change your package name accordingly.

  5. #5
    Join Date
    May 2010
    Beans
    3,239

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    What is in the new kernel that you need so badly or are you wanting to report bugs?

  6. #6
    Join Date
    Jun 2016
    Beans
    1

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    Same here.

    In theory there is a meta-package in mainline-jammy:

    sudo apt install linux-generic-6.05

    but it does not work for me currently (point to 6.5.5 which is absent ATM). This seems to work though:

    sudo apt install linux-headers-6.5-060500-generic linux-image-unsigned-6.5-060500-generic linux-modules-6.5-060500-generic


  7. #7
    Join Date
    Apr 2022
    Beans
    11

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    This makes complete sense thanks a lot.

  8. #8
    TenPlus1's Avatar
    TenPlus1 is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    May 2005
    Location
    Scotland, UK
    Beans
    920
    Distro
    Lubuntu

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    I use the Mainline app to install the latest 6.5.5 kernel and while it errors, I can easily remove the offending -headers file in Synaptic and it will run fine.

  9. #9
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,515
    Distro
    Ubuntu Development Release

    Re: kernel 6.5 fails to install because unmet dependencies libc6 > 2.38

    Quote Originally Posted by TenPlus1 View Post
    I use the Mainline app to install the latest 6.5.5 kernel and while it errors, I can easily remove the offending -headers file in Synaptic and it will run fine.
    I have noticed that also, but have never understood why. Does anyone know why it works with the header file uninstalled?
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •