Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: Headphone "locks" aound

  1. #31
    Join Date
    Feb 2014
    Location
    Chandler, AZ
    Beans
    42
    Distro
    Ubuntu

    Re: Headphone "locks" aound

    Quote Originally Posted by 1fallen View Post
    No not in default.pa but here for all sessions and applications that Auto Start.
    Code:
    gnome-session-properties
    /usr/bin/gnome-session-properties ? Add a shell script to run that pactl command?

  2. #32
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Headphone "locks" aound

    Gnome, I'll save my thought on that, but john163 just use this to pull-up the application needed here:
    Code:
    pavucontrol
    The Playback Tab is the best source to change your audio devices.
    See Screenshot
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #33
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Headphone "locks" aound

    Quote Originally Posted by john163 View Post
    /usr/bin/gnome-session-properties ? Add a shell script to run that pactl command?
    No just throw this command to a NEW Auto start.
    Code:
    pactl load-module module-combine-sink
    Name it anything that you will remember it by.
    But the Command portion has to read just like i posted
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  4. #34
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Headphone "locks" aound

    john163 I have found out that you may need to install this:
    Code:
    sudo apt install gnome-startup-applications
    And after its installed, search for "startup" to launch that option, there you can then add the Start-up.
    I just don't use Gnome so all that stuff is dependent on Desktop Environments.
    Good Luck I'm off to a Meeting.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  5. #35
    Join Date
    Feb 2014
    Location
    Chandler, AZ
    Beans
    42
    Distro
    Ubuntu

    Re: Headphone "locks" aound

    Quote Originally Posted by 1fallen View Post
    Gnome, I'll save my thought on that, but john163 just use this to pull-up the application needed here:
    Code:
    pavucontrol
    The Playback Tab is the best source to change your audio devices.
    See Screenshot
    I seem to be completely missing something. There is no option I can find anywhere that switches the sound from the headphones to the HDMI output.

    As for gnome, that's what Ubuntu ships with. It isn't like I decided to install something different.

  6. #36
    Join Date
    May 2008
    Beans
    3,983
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: Headphone "locks" aound

    Quote Originally Posted by john163 View Post
    I seem to be completely missing something. There is no option I can find anywhere that switches the sound from the headphones to the HDMI output.
    Using Ubuntu 22.04 with Gnome 42.9
    Applications > Settings > Sound > Output Device
    I have HDMI HD Audio & Headphones & JVC Headset Bluetooth.
    Play a song from Rhythmbox and toggle dynamically between all three output devices.

    Edit: I've just read post no. 3 where you mention your laptop and docking station. My output results are probably not useful. Apologies
    Last edited by tea for one; August 14th, 2023 at 11:01 PM.

  7. #37
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Headphone "locks" aound

    Quote Originally Posted by john163 View Post
    I seem to be completely missing something. There is no option I can find anywhere that switches the sound from the headphones to the HDMI output.
    @john163 can you run this command for me, and take a screenshot:
    Code:
    pavucontrol
    Attach it to your next reply.
    Quote Originally Posted by john163 View Post
    As for gnome, that's what Ubuntu ships with. It isn't like I decided to install something different.
    We each have different Environments that we either just become used to or prefer, Gnome is just not my cup of tea, and I have not used it since Gnome2.
    That's all there is to that story. If your happy with Gnome then just use it.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  8. #38
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Headphone "locks" aound

    Please don't take this as a bad thing, but this post is over 2 weeks old now, and i have to think all this related to the Session in use.
    I have 3 Linux OS's (Ubuntu Debian and Arch) installed here, and all work with combined sinks, and from your system-info yours should work as well, I'm just not sure Gnome on Wayland is helping here. (Of course I could be wrong)
    Here is one part of the recipe that will be needed across all restart's, and it is important to place in "/home/your_username/.config/autostart/"
    and inside that file copy this:
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Version=0.9.4
    Type=Application
    Name=Combined Audio
    Comment=
    Exec=pactl load-module module-combine-sink
    OnlyShowIn=GNOME;
    RunHook=0
    StartupNotify=false
    Terminal=false
    Hidden=false
    I've named mine "Combined Audio" for an easy look.
    Code:
    ls /home/me/.config/autostart | grep 'Combined Audio'
    Combined Audio.desktop
    Code:
    wpctl status | grep active
                 73. output_FL       > UOEOS Laptop Dock:playback_FL	[active]
                 74. output_FR       > UOEOS Laptop Dock:playback_FR	[active]
                 75. output_FL       > ALC257 Analog:playback_FL	[active]
                 76. output_FR       > ALC257 Analog:playback_FR	[active]
                 90. output_FL       > SRS-XB22:playback_FL	[active]
                 91. output_FR       > SRS-XB22:playback_FR	[active]
                 98. output_FR       > combined:playback_FR	[active]
                 99. output_FL       > combined:playback_FL	[active]
    This Thread should have been fixed if fixable in about 10 minutes, and not 2 weeks later.
    maybe someone else is better suited to help you going forward.
    Last edited by 1fallen; August 16th, 2023 at 05:58 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •