Results 1 to 3 of 3

Thread: Not showing terminal size during resize

  1. #1
    Join Date
    Feb 2009
    Location
    California
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Not showing terminal size during resize

    How to make gnome-terminal show the size (rows/columns) during resizing?

    This used to work. I just installed 23.04, and am using the default desktop environment (AFAIK gnome on Wayland).

    Loss of this feature will make me go back to xfce because I work on projects which use a coding standard requiring max 80-column lines, and so it is essential to be able to easily set terminals to be exactly 80 columns to easily see over-long lines when using vim.

    (The only reason I came back to gnome was that xfce does not support HiDPI displays very well and, reportedly, the latest ubuntu + gnome does)

  2. #2
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,497
    Distro
    Ubuntu Budgie

    Re: Not showing terminal size during resize

    This behavior has been exhibited on Wayland environments.

    You could install another term such as QTerminal.
    It will display the rows/columns during resizing under Wayland.
    /path/to/Truth

  3. #3
    Join Date
    Dec 2014
    Beans
    2,572

    Re: Not showing terminal size during resize

    Why are you playing around with a fragile solution (setting the terminal to a specific width) instead of setting a maximum line length in vi ? While vi isn't my editor of choice, I'm quite certain that it can do that (':help textwidth' in vi should give you the relevant part of the documentation if you have the vi documentation installed).

    Holger

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •