Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

  1. #11
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Now using WPA2 only and IPv6 is disabled but still same speed and getting same message in dmesg.
    Code:
      wlp5s0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded

  2. #12
    Join Date
    May 2014
    Location
    /home
    Beans
    10,927
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Code:
    echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlopt.conf
    reboot

  3. #13
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    @jeremy31, thanks for all the support. But it seems we are looking in different direction. Still same result. Afresh output from script is here.

  4. #14
    Join Date
    May 2014
    Location
    /home
    Beans
    10,927
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Post results for
    Code:
    iw dev

  5. #15
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Here it is

    Code:
    iw dev
    phy#0
        Unnamed/non-netdev interface
            wdev 0x3
            addr f8:63:3f:96:1b:c7
            type P2P-device
            txpower 0.00 dBm
        Interface wlp5s0
            ifindex 3
            wdev 0x1
            addr f8:63:3f:96:1b:c6
            ssid C511_5G
            type managed
            channel 149 (5745 MHz), width: 20 MHz, center1: 5745 MHz
            txpower 22.00 dBm
            multicast TXQ:
                qsz-byt    qsz-pkt    flows    drops    marks    overlmt    hashcoltx-bytes    tx-packets
                0    0    0    0    0    0    0    00

  6. #16
    Join Date
    May 2014
    Location
    /home
    Beans
    10,927
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Can you set the routers 5GHz channel to 42 or 58? Is there some option on the router to set the country you are in?

    It seems this problem is from Location Aware Regulatory that is in the iwlwifi driver and possibly others and it is ignoring the fact that we set the country code to JP and limits the channel bandwidth to 20 MHz

    I am not sure what this LAR searches for but it could be using your set time zone/location and that is not set to Japan
    If my recommended channels don't work see if you can find a channel that is allowed on the router that is outside the frequencies of this list
    Code:
    phy#0 (self-managed)
    country ID: DFS-UNSET
    	(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
    	(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
    	(2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
    	(5735 - 5815 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
    If it thinks you are in Indonesia then it won't allow channels 96-144 which is what the results look like. changing time zone or having the router use a channel in that range might work

  7. #17
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    Quote Originally Posted by jeremy31 View Post
    Can you set the routers 5GHz channel to 42 or 58? Is there some option on the router to set the country you are in?
    There is no option to set channels 42 or 58 or any other channel that is listed as 80MHz on wiki. Even 40MHz channels selection not an option. I suppose end devices do some channels bundling like mobile is showing 433Mb/s. So Ubuntu is failing to bundle channels.

    Quote Originally Posted by jeremy31 View Post
    It seems this problem is from Location Aware Regulatory that is in the iwlwifi driver and possibly others and it is ignoring the fact that we set the country code to JP and limits the channel bandwidth to 20 MHz
    I am setting the country code to ID. I've tried other codes as well including US, JP, AE but nothing works. Below command
    Code:
    sudo iw reg set XX
    only changes the global parameters and not the phy#0. Does below output mean that no 40MHz/80MHz are allowed/supported for this particular frequency range ?
    Code:
    (5735 - 5815 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
    Quote Originally Posted by jeremy31 View Post
    IIf my recommended channels don't work see if you can find a channel that is allowed on the router that is outside the frequencies of this list
    If I select a different channel on AP by changing the region which is outside the range of phy#0 list then laptop fails to scan it.

    Am I correct in understanding that for below output, global is what we set manually which only shows the corresponding parameters of frequnecies, bands, DFS etc. But actual working of driver is based on phy#0 ?

    Code:
    sudo iw reg get
    global
    country ID: DFS-JP
        (2400 - 2483 @ 40), (N/A, 26), (N/A), NO-OUTDOOR
        (5150 - 5350 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
        (5725 - 5825 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
    
    phy#0 (self-managed)
    country ID: DFS-UNSET
        (2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
        (2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
        (2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
        (5735 - 5815 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
    How can we change phy#0 country from ID to some other? The laptop was not bought from Indonesia.

  8. #18
    Join Date
    May 2014
    Location
    /home
    Beans
    10,927
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    You may have to change the wifi channel/time zone and reboot. It seems that some of the information is in iwlwifi firmware but the driver uses info from AP beacons to determine country https://bugzilla.kernel.org/show_bug.cgi?id=205695#c6
    The iw reg get info shows that only 20MHz bandwidth is allowed in the 5735-5815 range

  9. #19
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    I can not make anymore testing with that AP since going to leave this place. Will keep this thread open for any update.
    Thanks for all the time and help @jeremy31.

  10. #20
    Join Date
    Sep 2011
    Beans
    114
    Distro
    Ubuntu Mate 22.04 Jammy Jellyfish

    Re: Ubuntu 22.04 WiFi Only Connecting at 72Mb/s

    I am in a different city now and connected to a 5G WiFi. Now my laptop is connected at 433 Mbps. Ive already reverted all the changes that were suggested earlier in this thread but still its connecting at high speed. Few outputs posted here for reference.

    Code:
    iw reg get
    global
    country 00: DFS-UNSET
        (755 - 928 @ 2), (N/A, 20), (N/A), PASSIVE-SCAN
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
        (5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)
    
    phy#0 (self-managed)
    country US: DFS-UNSET
        (2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
        (2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
        (2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
        (5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5250 - 5270 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5270 - 5290 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5290 - 5310 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5310 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5490 - 5510 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5510 - 5530 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5530 - 5550 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5550 - 5570 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5570 - 5590 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5590 - 5610 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5610 - 5630 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5630 - 5650 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN
    Code:
    iwconfig wlp5s0 
    wlp5s0    IEEE 802.11  ESSID:"XXXX"  
              Mode:Managed  Frequency:5.765 GHz  Access Point: C0:74:AD:19:7A:D6   
              Bit Rate=433.3 Mb/s   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=65/70  Signal level=-45 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:9   Missed beacon:0
    Gonna mark the thread as SOLVED.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •