Results 1 to 2 of 2

Thread: No sound - ALC897 Analog sound card

  1. #1
    Join Date
    Sep 2013
    Beans
    8

    Question No sound - ALC897 Analog sound card

    Hi Everyone,

    I have a Beelink Ryzen 7 5800 H and installed Ubuntu 22.04 on it. I don't get any sound from the headphones jack on the front of the PC.

    Output of aplay -l:

    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Generic [HD-Audio Generic], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Generic [HD-Audio Generic], device 9: HDMI 3 [HDMI 3]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: Generic_1 [HD-Audio Generic], device 0: ALC897 Analog [ALC897 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Output of cat /proc/asound/modules:

    Code:
     0 snd_hda_intel
     1 snd_usb_audio
     2 snd_hda_intel
     3 snd_acp3x_rn
    My current alsa-base.conf:
    Code:
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from being loaded as first soundcard
    options snd-usb-audio index=-2
    
    #options snd_acp3x_rn index=0 model=generic
    options snd-hda-intel probe_mask=1
    The sound card, Renoir Radeon High Definition Audio Controller appears under Sound Preferences -> Hardware as Disabled/Off, and only 'Dummy Audio' appears in Sound Preferences -> Output.

    Sound does work via an HDMI cable, but my main monitor doesn't have speakers, and I would like to use speakers plugged into the headphones jack.

    Does anyone know how I should edit alsa-base.conf to make this card active? I've tried various solutions, mainly editing alsa-base.conf or creating a /etc/asound.conf file, but nothing seems to work, so I'm clearly missing something.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No sound - ALC897 Analog sound card

    I went with a full install of pipewwire: https://gist.github.com/the-spyke/2d...ent_id=3976215
    Code:
    inxi -A
    Audio:
      Device-1: NVIDIA driver: snd_hda_intel
      Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
      Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
      Device-4: C-Media Audio Adapter (Unitek Y-247A) type: USB
        driver: cmedia_hs100b,snd-usb-audio,usbhid
      Sound API: ALSA v: k6.2.0-20-generic running: yes
      Sound Server-1: PipeWire v: 0.3.65 running: yes
    If you follow that link you will need a reboot to see the changes.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •