Results 1 to 6 of 6

Thread: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2 is t

  1. #1
    Join Date
    Oct 2021
    Beans
    5

    23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2 is t

    I tried to upgrade from 22.10 to 23.04 and it spent a while doing it's thing and then the upgrade failed. My computer still seems to work OK, but just hasn't been upgraded.

    I have the error message below, any ideas how I can fix this?

    Code:
    The following packages have unmet dependencies.
     libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2 is to be installed
    E: Broken packages

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    14,193
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2

    matthewbaynham

    When I run and compare
    Code:
    apt show libtbb2-dev
    apt show libtbb-dev
    Both show the same fuctionality.

    And then there is the versions installed ambiquity . Our repo shows:
    kinetic (22.10) (libdevel): parallelism library for C++ - development files [universe]
    2021.5.0-15ubuntu1:
    which raises the question of where the elevated version: "2021.8.0-1ubuntu2 is to be installed" comes from.

    Please post back:
    Code:
    apt policy libtbb2-dev libtbb-dev
    And see about purging one of these.

    there can be only one
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Oct 2021
    Beans
    5

    Re: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2

    I'm confuse, so I just ran what you typed and here is what it shows me

    Code:
    matthew@matthew-desktop:~$ apt show libtbb2-dev
    Package: libtbb2-dev
    Version: 2020.3-2.1ubuntu1
    Status: install ok installed
    Priority: optional
    Section: libdevel
    Source: tbb
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
    Installed-Size: 2.043 kB
    Depends: libtbb2 (= 2020.3-2.1ubuntu1)
    Suggests: libtbb2-doc
    Conflicts: libtbb-dev
    Replaces: libtbb-dev (<< 2020.3-1ubuntu1)
    Homepage: https://www.threadingbuildingblocks.org/
    Download-Size: unknown
    APT-Manual-Installed: yes
    APT-Sources: /var/lib/dpkg/status
    Description: parallelism library for C++ - development files
     TBB is a library that helps you leverage multi-core processor
     performance without having to be a threading expert. It represents a
     higher-level, task-based parallelism that abstracts platform details
     and threading mechanism for performance and scalability.
     .
     (Note: if you are a user of the i386 architecture, i.e., 32-bit Intel
     or compatible hardware, this package only supports Pentium4-compatible
     and higher processors.)
     .
     This package includes the TBB development files.
    Code:
     matthew@matthew-desktop:~$ apt show libtbb-dev
    Package: libtbb-dev
    Version: 2021.8.0-1ubuntu2
    Priority: extra
    Section: universe/libdevel
    Source: onetbb
    Origin: Ubuntu
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
    Bugs: https://bugs.launchpad.net/ubuntu/+filebug
    Installed-Size: 1.463 kB
    Depends: libtbb12 (= 2021.8.0-1ubuntu2)
    Suggests: libtbb-doc
    Homepage: https://www.threadingbuildingblocks.org/
    Download-Size: 191 kB
    APT-Sources: http://archive.ubuntu.com/ubuntu lunar/universe amd64 Packages
    Description: parallelism library for C++ - development files
     TBB is a library that helps you leverage multi-core processor
     performance without having to be a threading expert. It represents a
     higher-level, task-based parallelism that abstracts platform details
     and threading mechanism for performance and scalability.
     .
     (Note: if you are a user of the i386 architecture, i.e., 32-bit Intel
     or compatible hardware, this package only supports Pentium4-compatible
     and higher processors.)
     .
     This package includes the TBB development files.
    Code:
    matthew@matthew-desktop:~$ apt policy libtbb2-dev libtbb-dev
    libtbb2-dev:
      Installed: 2020.3-2.1ubuntu1
      Candidate: 2020.3-2.1ubuntu1
      Version table:
     *** 2020.3-2.1ubuntu1 100
            100 /var/lib/dpkg/status
    libtbb-dev:
      Installed: (none)
      Candidate: 2021.8.0-1ubuntu2
      Version table:
         2021.8.0-1ubuntu2 500
            500 http://archive.ubuntu.com/ubuntu lunar/universe amd64 Packages

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    14,193
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2

    matthewbaynham - slightly surprised
    Hummm ...

    As we have:
    Candidate: 2021.8.0-1ubuntu2
    and however, the repo version:
    libtbb-dev/jammy 2021.5.0-7ubuntu2 amd64
    let's dig a bit and see if we can determine where that elevated version derives.
    Please post back:
    Code:
    cat -n /etc/apt/sources.list
    tail -v -n +1 /etc/apt/sources.list.d/*
    Because these are optional to install, once we know how, we can safely purge them from the system; then do a re-do.

    -inquiring minds want to know-
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  5. #5
    Join Date
    Jun 2020
    Beans
    66

    Re: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2

    I tried upgrading from Ubuntu 22.10 to 23.04. At one point there was a message to accept MS fonts with a box to check & to okay that. It wouldn't accept my clicking on okay. The system froze & left with broken system. I had to reinstall Ubuntu 22.04 from a ISO disc and lost all data from previous install. Anyone else have this problem?

  6. #6
    Join Date
    Jun 2020
    Beans
    66

    Re: 23.04 upgrade failed - libtbb2-dev : Conflicts: libtbb-dev but 2021.8.0-1ubuntu2

    Found the answer. You must hit the tab and then you can hit okay.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •