Results 1 to 4 of 4

Thread: 1660 Super Driver Problems

Threaded View

  1. #1
    Join Date
    Apr 2017
    Beans
    11

    Angry 1660 Super Driver Problems

    Hi all,

    Hardware:
    Gigabyte b450m
    Ryzen 4500
    32gb memory (don't remember mfg)
    Nvidia 1660 Super

    I put everything together new a week ago and it worked superbly! However, recently, I switched drivers to the 525 proprietary NVIDIA driver and messed some with mesa libraries (https://itsfoss.com/install-mesa-ubuntu/). This provided unsatisfactory results so I reverted to the nouveau drivers and uninstalled mesa updates. However, when I did so, two things changed:
    -psensor would not give me any GPU details (nvctrl failed to retrieve NVIDIA information error)
    -Steam games that I ran with proton (compatibility layer) would no longer run (PvZ GW2, Postmouse)

    After quite a bit of trying to fix things and nothing working, I decided to completely reinstall Ubuntu thinking this would fix my problems. It didn't. psensor still can't get graphics card info and Postmouse runs, albeit incredibly slowly (waiting for PvZ GW2 to download). I also tried disconnecting all cables and rebooting, but this didn't change anything. If you think GPU temperatures are the problem:
    1. I do have a custom watercooling solution that gets the GPU but not the memory or vrm sections
    but 2. issues only started when I messed with drivers and not during intense gameplay, plus the card still works to some degree,
    3. temps looked great before I messed with drivers (never above 45C)
    and 4. I can't get temperatures now because psensor can't get them!

    I'm sorry if some of this came off as a ramble, I'm just really frustrated that even a complete reinstall hasn't fixed my issues (plus it was really nice to play some of these games on a new card, I'm upgrading from a 740). I suspect some flag got set on my gpu when I messed with the drivers and didn't get reset, maybe there's some way to factory hardware reset my card??

    EDIT: There's a substantial difference between 525-open and 525. 525-open is the one I tested previously. If I go to 525, I can get the original performance that I wanted (psensor can read from card, graphics are fast). This issue may still help nouveau developers debug this behavior.

    EDIT 2: Should've left good enough alone. Can't get back to 525. I keep getting the error pk-client-error-quark error during installation. Both dpkg --configure -a and apt install -f return errors.
    Last edited by d-v-t; April 15th, 2023 at 05:25 AM. Reason: more testing

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •