The PC is quite old but works fine, my first time with linux. Installed 22.10. I have been trying to link my bluetooth earphones today, today if I activate my bluetooth in settings or on the top right and I leave the system for about 2 or 3 minutes, the internet connection stops working. Despite this I can see the internet link is absolutely fine, I can swich it on, swich it off, it finds the link, but if I want to go to a page... it just waits and waits. It never says no internet is available. But when I swich the bluetooth off again and wait for 2 or 3 minutes... the internet works 100%.
So it is quite difficult and useless to find a answer because even if they worked, I would not be able to use them for anything because I cannot get online.

If this will make any difference, if I go to the settings page, and swhich bluetooth on (there it does the same), but it just keeps on searching for devices and never finds these even though they are switched on. To see if the earphones worked I tried them on my phone and they are 100% and they always worked on Windows. But the problem is obviously the fact that my online link stops.
Also, I have a SAMSUNG phone linked to bluetooth, which is not connected on settings (that I eventually got linked the other day... but still not the headphones that I am trying today). ? Something to do with the fact that the SAMSUNG is linked (but switched off) AND I did not have this problem while I was trying to link the phone??

Can anyone help me with this.

Thanks
Johan