Results 1 to 2 of 2

Thread: Ubuntu 20.04 LTS Make Headphones Work (full script inc)

  1. #1
    Join Date
    Nov 2016
    Beans
    76

    Ubuntu 20.04 LTS Make Headphones Work (full script inc)

    Hi,

    After a few updates, I only recently discovered that my headphones were working but not giving any sound anylonger on my (L)Ubuntu 20.04 LTS.
    Absolutely the Best Solution seemed to be this tiny code
    Code:
    alsactl restore
    Processed in a clickable bash script (make executable, keep at hand, possibly copy to Desktop):

    Code:
    #!/bin/bash
    
    clear
    
    TITLE="HEADPHONES ON"
    echo -en "\033]0;$TITLE\a" # Window title
    
    echo "$TITLE"
    
    echo
    
    echo "Reset alsa in order to hear headphones..."
    
    echo
    
    alsactl restore
    
    echo
    
    sleep 1
    
    echo "Done."
    
    echo
    
    echo "Window closes automatically in 3 seconds..."
    
    sleep 3
    
    exit
    
    read
    As I've heard the issue doesn't occur anymore in a later Ubuntu version.
    Alsa, Pulse - things can become mixed up.
    Last edited by xinuzi; March 28th, 2023 at 07:45 AM. Reason: minor adaptations

  2. #2
    Join Date
    Nov 2016
    Beans
    76

    Smile Re: Ubuntu 20.04 LTS Make Headphones Work (full script inc)

    No headphone struggles indeed in (L)Ubuntu 22.04 .

    Alsamixer vs pulse audio, things can be confusing but when one looks better the settings are there, also gui-wise.

    Like these settings, when you rightclick the taskbar sound-icon (as it shows in Lubuntu):





    ('ingebouwde analoge stereo' = 'analogue stereo')
    (Image 1 shows a locked panel. Unlock to set.)

    This setting makes the sound icon in the taskbar work well.
    Extra settings of the sound(s) by clicking the sound taskbar/panel sound-button and then 'Mixer'.

    Volume/sound configurations to keep an eye on, are the analogue (pc) setting vs the hdmi setting.

    Tothelooo.
    Attached Images Attached Images
    Last edited by xinuzi; March 29th, 2023 at 07:45 AM. Reason: minor adaptations

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •