There is a confirm problem with VMwares's vmx-svga module, especially when you try to enable 3D graphics in VM's. There are many threads on this in the VMware and Promox forums.

Their fix was to suppress the kernel warnings by adding the following as a boot parameter to the boot line in /etc/default grub: