Results 1 to 3 of 3

Thread: Grub command line - Bios Compatibility Mode error message when running Boot repair

  1. #1
    Join Date
    Dec 2022
    Beans
    1

    Grub command line - Bios Compatibility Mode error message when running Boot repair

    Hi everyone - I'm new to Ubuntu and having some issues. I am trying to overwrite an old laptop with Windows 10 previously installed with Ubuntu. I only want Linux on the laptop (no more Windows!). The laptop is a Dell Latitude 5590.

    I installed Ubuntu using a SD card image over the existing operating system. It didn't seem to work the first time - it never opened when I restarted it - so used the SD card and I did it again. The second time I overwrote the previous installation and got a fatal error - failure to install the boot data. Now when I restart it takes me into the terminal line at grub>_

    So I checked this online forum and learned how to make a live usb. I have the live usb running now. When I run boot repair and try to run the recommended repairs I get this message:


    The current session is in BIOS-compatibility mode. Please disable BIOS-compatibility/CSM/Legacy mode in your UEFI firmware, and use this software from a live-CD (or live-USB) that is compatible with UEFI booting mode. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.

    I ran boot repair info - see attached text file. I've tried to reboot and modify my BIOS settings and disable legacy mode but then it does not allow me to boot into the LiveUSB and I just get to the command line at grub>

    I've seen some similar problems listed on the forum here but they seem to be fairly specific situations with steps that I am not sure I need to follow. So - I'm not sure where to go from here - I'm barely literate with computers and could use some help. Thank you in advance.

    Attached Files Attached Files

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Grub command line - Bios Compatibility Mode error message when running Boot repai

    Most will not download an unknown file.
    You should have followed suggestion by Boot-Repair to post the link to the summary report.

    You have UEFI system.
    But have installed in both BIOS/Legacy/CSM boot mode and in UEFI boot mode.
    CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off.

    The first partition bios_grub is for part of grub using BIOS boot on gpt partitioned drives.
    The second partition ESP - efi system partition if for UEFI boot files.

    You must be consistent, or always boot in UEFI mode, since hardware is UEFI.
    But then you must boot live installer/Flash drive in UEFI mode. It should show in boot menu as UEFI : xxx , BIOS boot would be just xxx.
    And then system default boots full install in mode you have set in UEFI settings. Make sure that is set for UEFI boot.

    You may need to boot live installer in UEFI mode & reinstall grub with Boot-Repair, so settings are all UEFI.
    Last edited by oldfred; December 29th, 2022 at 10:55 PM.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    May 2008
    Beans
    4,133
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Grub command line - Bios Compatibility Mode error message when running Boot repai

    Quote Originally Posted by markahlstrom View Post
    I ran boot repair info - see attached text file. I've tried to reboot and modify my BIOS settings and disable legacy mode but then it does not allow me to boot into the LiveUSB and I just get to the command line at grub
    Power off the PC.
    Attach your bootable USB.
    Power on and tap (one second intervals) the dedicated key (F12 for Dell?) to access the one-time boot menu.
    When you arrive at the boot menu, you should see an entry beginning with UEFI:name of disk (i.e.UEFI followed by colon followed by Kingston or Sandisk etc)
    This will boot your live USB in UEFI mode.
    Have a look at this image for more clarification
    Attached Images Attached Images
    Last edited by tea for one; December 30th, 2022 at 02:28 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •