Results 1 to 7 of 7

Thread: Grub booting windows11 into sleep mode

  1. #1
    Join Date
    Nov 2022
    Beans
    4

    Grub booting windows11 into sleep mode

    Hi all,
    I've just installed ubuntu 22.04 as dual boot on a windows 11 NUC and now selecting windows boot loader from the grub menu sends the box to sleep. I need to press the power button twice (once off and once on) before it will display the windows log-on screen. (Note - it doesn't reboot here, it just wakes up).
    Windows will boot fine if selected to be first in my bios (i.e - launching the windows boot manager and not grub), so I'm guessing it's a grub issue.
    I have the option of adding ubuntu to the windows boot loader and using that instead, but it would be nice if I could get grub working.
    Does anyone have any ideas where I could start looking please? My web searches have come up blank so far.

    Thanks in advance

  2. #2
    Join Date
    Jun 2014
    Beans
    7,440

    Re: Grub booting windows11 into sleep mode

    You could try turning off Secure Boot and hibernation in windows to see if that resolves the problem.

  3. #3
    Join Date
    Nov 2022
    Beans
    4

    Re: Grub booting windows11 into sleep mode

    All the windows sleep options are off, secure boot and fast boot are also already off - these have no effect.
    Interestingly, if I select the windows option in Grub and hit 'e' to bring up the edit screen, I can then just continue to boot into windows from there and it loads fine.
    There's just something odd happening with the initial Grub menu.

  4. #4
    Join Date
    May 2008
    Beans
    4,043
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Grub booting windows11 into sleep mode

    Quote Originally Posted by dotborg2 View Post
    Interestingly, if I select the windows option in Grub and hit 'e' to bring up the edit screen, I can then just continue to boot into windows from there and it loads fine.
    That's a bit unusual.
    I would boot into Ubuntu and run:-
    Code:
    sudo update-grub
    Make sure that you have this entry in etc/default/grub
    Code:
    GRUB_DISABLE_OS_PROBER=false
    Any improvement?

  5. #5
    Join Date
    Nov 2022
    Beans
    4

    Re: Grub booting windows11 into sleep mode

    No luck with those either I'm afraid, I'm suspecting a hardware issue now to be honest. With a bit of luck I can still exchange it.
    The help is much appreciated anyway.
    Thanks to all.

  6. #6
    Join Date
    Mar 2023
    Beans
    1

    Re: Grub booting windows11 into sleep mode

    You should turn off Secure Boot in windows and give it a try. Who know if this work for you. https://thedigitalbin.com




  7. #7
    Join Date
    Nov 2022
    Beans
    4

    Re: Grub booting windows11 into sleep mode

    This ended up being a hardware issue and was resolved with a fix from the manufacturer (an issue with the hdmi ports..). Thanks all anyway.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •