Quote Originally Posted by cigtoxdoc View Post
After much troubleshooting, I found the only culprit being the "Slow Keys" setting under Universal Access had been turned on. Solution was to turn it off.

John
There are 2 different places for input (keyboard/mouse) stuff. They are separate because the GUI isn't part of the OS and it is just another program.

1 is for the console.
2 is for the display server - i.e. X/Windows or Wayland.

Both need to be modified to work for console and GUI. In X/Windows, there a keyboard map file and some way to deal with specific configurations. I suspect that's what the DEs do ... but if you change to a different DE, then those settings won't come along. I know next to nothing about how Wayland works and suspect it requires the DE settings to control anything, but I don't really know.