Hello,

this issue has happened some time now, yet I didn't have the time to post it. Unfortunately, I tried many solutions and no one worked. So you will ask: why to post this now?

In case someone faces that problem, searching the internet will find many solutions. In my case none worked. To name but a few differences that I had with these solutions and I remember were: I had sound from viber messages, aplay -l showed soundcard output instead of having null output. I remember that I changed kernel to no avail, followed this:
https://aaroalhainen.medium.com/how-...e-eaa525838e0d,
to no avail either, except from the fact that I didn't have timidity.

So I tried a new kinetic (new at that time) startup disk and saw that when I chose the option (try ubuntu) my sound was recognized as it used to. Then I proceeded in a fresh installation of 22.10 and everything was (still is) fine. As a result, I'm posting this in case you face the same problem, when upgrading from 22.04 to 22.10, to try "that solution" as well and save time. It's not an actual solution, since you have to reinstall, at least you know that the latest version will support your sound card and something was messed up during your upgrade.

Regards!