Results 1 to 8 of 8

Thread: operating system problem

  1. #1
    Join Date
    Jun 2022
    Beans
    9

    operating system problem

    Codes don't work, can't install anything
    sudo apt-get install apache2(and many other codes)

  2. #2
    Join Date
    May 2008
    Beans
    4,144
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: operating system problem

    Can you navigate to https://github.com/UbuntuForums/system-info and peruse the information.
    Then, if you are happy with the software and its intention, run the script and pop the report in this thread.

  3. #3
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    7,731

    Re: operating system problem

    Let's start with sudo apt-get install apache2. Can you post exactly what you typed, and what the response was? Then we can have a look and think about it.
    Copy and paste is much better than posting screenshots for this.

  4. #4
    Join Date
    Jun 2022
    Beans
    9

    Re: operating system problem

    I'll try later

  5. #5
    Join Date
    Mar 2011
    Beans
    2,026

    Re: operating system problem

    Did you first run sudo apt-get update ? Then try your installs.

  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: operating system problem

    Just a note about terminology.

    "Codes" generally relates to gaming. It's not a term we use here much.

    What you are talking about are "commands". You issue commands in the terminal. You don't type codes.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    Jun 2022
    Beans
    9

    Re: operating system problem

    Code:
    zongmans:~$ sudo apt-get install apache2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     apache2 : Depends: apache2-bin (= 2.4.41-4ubuntu3.11) but it is not going to be installed
               Depends: apache2-utils (= 2.4.41-4ubuntu3.11)
    E: Unable to correct problems, you have held broken packages.
    Last edited by ajgreeny; June 15th, 2022 at 05:10 PM. Reason: Code tags added

  8. #8
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: operating system problem

    As others suggested,

    Code:
    sudo apt-get update
    sudo apt-get full-upgrade
    sudo apt-get -f install
    Then you can try installing whatever new packages you like, assuming each of those commands complete without errors. If they have any errors - STOP. DO NOT CONTINUE. Post the exact command and the error output back here for more advice.

    Plus, it is really nice when forum code-tags are used for all terminal input/output.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •