Results 1 to 3 of 3

Thread: How can I increase the font size at bash terminal?

  1. #1
    Join Date
    Mar 2022
    Beans
    1

    How can I increase the font size at bash terminal?

    Dear, my Ubuntu Server (latest version) is running into VirtualBox Machine. However, the font size is small. I'm not able to see the letters very well. How can I increase the font size at bash terminal?

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: How can I increase the font size at bash terminal?

    Bash is a shell, not a terminal.

    Which terminal program are you using? There are about 20 of them commonly used. I prefer a true xterm, but most DEs come with a bloated terminal - say lxterm, gnome-terminal, or something similar. From Windows, puTTY is popular. They all work fine. Most of those terminals will have a font-chooser either in the menus or through a well-known <cntl>-+ larger method. xterms have a popup menu called VT Fonts, which is accessed using the <cntl>-right-click (hold it until the menu appears), then select the font you like.

    Also, if you are running Ubuntu Server (no GUI at all), then I truly hope you are using a different workstation and ssh into the server from another box with a real terminal and full X/Windows select/paste capabilities. If not, then you are doing it the hard way.

    Virtualbox has a way to increase the size of the screen if you are truly at a console. It is in the virtualbox menus surrounding the screen - resize to fit window is one of the options that I vaguely recall. The virtualbox manual, available online will detail the solution. Google finds it easily.

  3. #3
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How can I increase the font size at bash terminal?

    Adding to what TheFu said...

    If you are talking about 'Terminal' as a graphical terminal session application, go into the preferences and change the font and/or font size...

    If you are talking about a vTTY or other Console session, then either change the reslotution of vTTY in Grub, reconfigure 'console-setup' or use the Linux utility 'setcon'.

    To reconfigure 'console-setup':
    Code:
    sudo --configure console-setup
    In two panel's of the setup, you will find "Font' and "Font size"...

    TheFu suggests if you are 'Console Based' to use another app/layer to live in... I mostly used to use Console based session manager's such as Byobu... but now find myself using TMux and Terminator more and more... with 'fg' helping each... Even when using 'i3' as a Desktop Environment... My Ama-Gi Project LiveCD is mostly' Console Based', with an on-demand minimal Desktop as an option...

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •