Results 1 to 4 of 4

Thread: crash during upgrade from Ubuntu 21.04 to 21.10

  1. #1
    Join Date
    Jul 2011
    Location
    Slovakia
    Beans
    315
    Distro
    Kubuntu

    Question crash during upgrade from Ubuntu 21.04 to 21.10

    Hi,

    I already upgraded several times my laptop and my desktop computers since ubuntu 16.x
    While upgrade from v21.04 to 21.10 has been without trouble on desktop computer, it crashed on my laptop.

    Now, I have several hundred (1615) packages not installed and when I try to install them I get the following errors:
    Code:
    Setting up systemd (248.3-1ubuntu8) ...
    systemd-machine-id-setup: error while loading shared libraries: libsystemd-shared-247.so: cannot open shared object file: No such file or directory
    dpkg: error processing package systemd (--configure):
     installed systemd package post-installation script subprocess returned error exit status 127
    Errors were encountered while processing:
     systemd
    
    I tried to use :
    sudo dpkg --configure -a

    result is:
    Code:
    etting up systemd (248.3-1ubuntu8) ...
    systemd-machine-id-setup: error while loading shared libraries: libsystemd-shared-247.so: cannot open shared object file: No such file or directory
    dpkg: error processing package systemd (--configure):
     installed systemd package post-installation script subprocess returned error exit status 127
    dpkg: dependency problems prevent configuration of netplan.io:
     netplan.io depends on systemd (>= 248~); however:
      Package systemd is not configured yet.
    
    dpkg: error processing package netplan.io (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of dbus-user-session:
     dbus-user-session depends on systemd; however:
      Package systemd is not configured yet.
    
    dpkg: error processing package dbus-user-session (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libpam-systemd:amd64:
     libpam-systemd:amd64 depends on systemd (= 248.3-1ubuntu8); however:
      Package systemd is not configured yet.
    
    dpkg: error processing package libpam-systemd:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of policykit-1:
     policykit-1 depends on default-logind | logind; however:
      Package default-logind is not installed.
      Package libpam-systemd:amd64 which provides default-logind is not configured yet.
      Package logind is not installed.
      Package libpam-systemd:amd64 which provides logind is not configured yet.
    
    dpkg: error processing package policykit-1 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of systemd-sysv:
     systemd-sysv depends on systemd (= 248.3-1ubuntu8); however:
      Package systemd is not configured yet.
     systemd-sysv depends on systemd; however:
      Package systemd is not configured yet.
    
    dpkg: error processing package systemd-sysv (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-settings-daemon:
     gnome-settings-daemon depends on default-logind | logind; however:
      Package default-logind is not installed.
      Package libpam-systemd:amd64 which provides default-logind is not configured yet.
      Package logind is not installed.
      Package libpam-systemd:amd64 which provides logind is not configured yet.
    
    dpkg: error processing package gnome-settings-daemon (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gparted:
     gparted depends on policykit-1; however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package gparted (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-manager:
     update-manager depends on policykit-1; however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package update-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libnss-systemd:amd64:
     libnss-systemd:amd64 depends on systemd (= 248.3-1ubuntu8); however:
      Package systemd is not configured yet.
    
    dpkg: error processing package libnss-systemd:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of network-manager:
     network-manager depends on policykit-1; however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package network-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of network-manager-pptp:
     network-manager-pptp depends on network-manager (>= 1.2.0); however:
      Package network-manager is not configured yet.
    
    dpkg: error processing package network-manager-pptp (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of polkit-kde-agent-1:
     polkit-kde-agent-1 depends on policykit-1; however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package polkit-kde-agent-1 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-shell:
     gnome-shell depends on gnome-settings-daemon (>= 40~); however:
      Package gnome-settings-daemon is not configured yet.
    
    dpkg: error processing package gnome-shell (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-session:
     ubuntu-session depends on gnome-settings-daemon (>= 3.37.0); however:
      Package gnome-settings-daemon is not configured yet.
     ubuntu-session depends on gnome-shell (>= 3.37.91); however:
      Package gnome-shell is not configured yet.
    
    dpkg: error processing package ubuntu-session (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gdm3:
     gdm3 depends on gnome-settings-daemon (>= 3.37.0); however:
      Package gnome-settings-daemon is not configured yet.
     gdm3 depends on gnome-shell (>= 3.37.90); however:
      Package gnome-shell is not configured yet.
     gdm3 depends on libpam-systemd; however:
      Package libpam-systemd:amd64 is not configured yet.
     gdm3 depends on policykit-1 (>= 0.105-5~); however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package gdm3 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-gtk:
     ubuntu-release-upgrader-gtk depends on update-manager; however:
      Package update-manager is not configured yet.
    
    dpkg: error processing package ubuntu-release-upgrader-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-notifier:
     update-notifier depends on update-manager-gnome | update-manager (>= 1:17.04.3); however:
      Package update-manager-gnome is not installed.
      Package update-manager is not configured yet.
     update-notifier depends on ubuntu-release-upgrader-gtk; however:
      Package ubuntu-release-upgrader-gtk is not configured yet.
     update-notifier depends on policykit-1; however:
      Package policykit-1 is not configured yet.
    
    dpkg: error processing package update-notifier (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of plasma-desktop:
     plasma-desktop depends on polkit-kde-agent-1 (>= 4:5.22~); however:
      Package polkit-kde-agent-1 is not configured yet.
    
    dpkg: error processing package plasma-desktop (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-remote-desktop:
     gnome-remote-desktop depends on gnome-shell (>= 3.37.92-2~) | budgie-desktop (>= 10.5.2); however:
      Package gnome-shell is not configured yet.
      Package budgie-desktop is not installed.
    
    dpkg: error processing package gnome-remote-desktop (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     systemd
     netplan.io
     dbus-user-session
     libpam-systemd:amd64
     policykit-1
     systemd-sysv
     gnome-settings-daemon
     gparted
     update-manager
     libnss-systemd:amd64
     network-manager
     network-manager-pptp
     polkit-kde-agent-1
     gnome-shell
     ubuntu-session
     gdm3
     ubuntu-release-upgrader-gtk
     update-notifier
     plasma-desktop
     gnome-remote-desktop
    
    
    I'm not able to upgrade a single package nor to fix this issue. I found several bugs reports written about this issue but no fix till now.
    Can you tell me what to do ? Has someone already solved this issue ?

    thx
    what does not kill you, makes you stronger

    Ubuntu 21.10 - KDE Plasma 5.22.5 - Kernel 5.13.x

  2. #2
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    6,125
    Distro
    Xubuntu

    Re: crash during upgrade from Ubuntu 21.04 to 21.10

    This may be solvable, but the normal approach to a release upgrade gone wrong is a fresh install. Easy, quick and you know for sure that the issue is gone.

  3. #3
    Join Date
    Jul 2011
    Location
    Slovakia
    Beans
    315
    Distro
    Kubuntu

    Re: crash during upgrade from Ubuntu 21.04 to 21.10

    This is what I've done as I did not find any valuable answer.
    Fortunatelly I had the whole /home on another drive so I lost only installed apps.
    what does not kill you, makes you stronger

    Ubuntu 21.10 - KDE Plasma 5.22.5 - Kernel 5.13.x

  4. #4
    Join Date
    Mar 2007
    Beans
    1,187

    Re: crash during upgrade from Ubuntu 21.04 to 21.10

    This seems to be the first issue:

    Code:
    systemd-machine-id-setup: error while loading shared libraries: libsystemd-shared-247.so: cannot open shared object file: No such file or directory
    That library seems to be missing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •