Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Ubuntu on Rapberry Pi won't display on large screen TV

  1. #1
    Join Date
    Apr 2008
    Beans
    20

    Ubuntu on Rapberry Pi won't display on large screen TV

    I have setup Ubutnu Desktop v21.10 on my Rapberry Pi 4.
    On my 24" monitor using an HDMI cable, it works fine.
    I'd like to set it up on my 65" Samsung TV, but the TV is not recognizing it. When I boot the Pi, the rainbow screen appears on the TV, but then it goes black, and the TV says it cannot find the source.

    I've tried adding these settings to /boot/firmware/config.txt in various combinations, but none of them have helped:
    disable_overscan=1
    hdmi_drive=2
    hdmi_force_hotplug=1
    hdmi_enable_4kp60=1

    I was previously running the Raspberry PI OS with this same hardware and TV, and it worked, so I don't think it's a hardware issue.

    Any ideas for anything else I can try?

  2. #2
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    This thread and this post may help you... Instead of retyping and reposting everything I answered there.
    https://ubuntuforums.org/showthread....9#post14055389

    Read through it and ask if you have any questions... it continued on past that.

    What is boils down to, is that the Raspberry Pi cannot always find what is the preferred mode in a TV's EDID table... It can possibly show a lot of different resolution ranges, but that is not always appropriate for the Display. It tries... But sometimes fails and selects something that is out of range of the display.

    This is how I setup my own my own Raspberry Pi4 8GB...
    Last edited by MAFoElffen; November 26th, 2021 at 06:51 AM.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  3. #3
    Join Date
    Apr 2008
    Beans
    20

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    Thanks for the response. I checked out the other thread you referenced, and it looks like he was having a problem very similar to mine, but it doesn't look like he ever resolved it. I tried some of the different HDMI settings you had listed in your usercfg.txt, but none of the ones I tried worked.

    Do you have anything else I can try? Should I continue posting here or add to the other thread?

  4. #4
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    What is the Brand and model of the Target Large Screen TV?

    Still on HDMI1?

    What is your target Resolution or mode?

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  5. #5
    Join Date
    Apr 2008
    Beans
    20

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    My TV is a Samsung 65" NU740D Smart 4K UHD TV

    This is the manual for it. The picture sizes and input signals are listed on page 134.
    https://downloadcenter.samsung.com/c...G_201023.0.pdf

    In case you can't get to it, it lists these input signals for a 16:9 picture size:
    HDMI (720p)
    HDMI (1080i, 1080p)
    HDMI (3840 x 2160p)
    HDMI (4096 x 2160p)
    *HDMI (7680 x 4320p @ 30 Hz)

    On page 136, it says this:
    Read Before Connecting a Computer (Supported Resolutions)
    Check the resolutions supported for PC input signals.
    When you connect your TV to a computer, set the computer's video card to one of the standard resolutions listed in
    the tables below or on the next page. The TV will automatically adjust to the resolution you choose. Note that the
    optimal and recommended resolution is 3840 x 2160 at 60 Hz. Choosing a resolution not included in the tables can
    result in a blank screen or just the power indicator turning on. Refer to the user manual of your graphics card for
    compatible resolutions
    So, here is my /boot/firmware/config.txt and the beginning part of /boot/firmware/usercfg.txt:
    Code:
    [pi4]
    max_framebuffers=2
    
    [all]
    kernel=vmlinuz
    cmdline=cmdline.txt
    initramfs initrd.img followkernel
    
    # Enable the audio output, I2C and SPI interfaces on the GPIO header
    dtparam=audio=on
    dtparam=i2c_arm=on
    dtparam=spi=on
    
    # Enable the KMS ("full" KMS) graphics overlay, and allocate 128Mb to the GPU
    # memory. The full KMS overlay is required for X11 application support under
    # wayland
    dtoverlay=vc4-kms-v3d
    gpu_mem=128
    
    # Uncomment the following to enable the Raspberry Pi camera module firmware.
    # Be warned that there *may* be incompatibilities with the "full" KMS overlay
    #start_x=1
    
    # Comment out the following line if the edges of the desktop appear outside
    # the edges of your display
    disable_overscan=1
    
    # If you have issues with audio, you may try uncommenting the following line
    # which forces the HDMI output into HDMI mode instead of DVI (which doesn't
    # support audio output)
    #hdmi_drive=2
    
    # If you have a CM4, uncomment the following line to enable the USB2 outputs
    # on the IO board (assuming your CM4 is plugged into such a board)
    #dtoverlay=dwc2,dr_mode=host
    
    # Config settings specific to arm64
    arm_64bit=1
    dtoverlay=dwc2
    include usercfg.txt
    Code:
    # Place "config.txt" changes (dtparam, dtoverlay, disable_overscan, etc.) in
    # this file. Please refer to the README file for a description of the various
    # configuration files on the boot partition.
    ## Custom Slot is hdmi_grpoup=1 & hdmi_mode=65
    ### For this define, it uses mode 87, which is 1 above the defined modes...
    #### Custom mode define ####
    # hdmi_cvt=<width> <height> <framerate> <aspect> <margins> <interlace> <rb>
    # width        width in pixels
    # height       height in pixels
    # framerate    framerate in Hz
    # aspect       aspect ratio 1=4:3, 2=14:9, 3=16:9, 4=5:4, 5=16:10, 6=15:9
    # margins      0=margins disabled, 1=margins enabled
    # interlace    0=progressive, 1=interlaced
    # rb           0=normal, 1=reduced blanking
    ###
    hdmi_cvt=3840 2160 60 3 0 0 0    # Custom mode definition
    #hdmi_group=2
    #hdmi_mode=87    #1 mode above defines in AEC
    ### Normal Mode Sets
    #hdmi_group=2     # 0:Autodetect EDID, 1:AEC, 2:DMT
    #hdmi_mode=86     # 1366x768, 60Hz,16:9, reduced blanking
    ### For sound through HDMI ###
    #hdmi_drive=1     # hdmi without soundhdmi_group=2     # 0:Autodetect EDID, 1:AEC, 2:DMT
    ### For sound through HDMI ###
    #hdmi_drive=2    # hdmi with sound

  6. #6
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    In your last post, I saw the link in the config.txt to the usercfg.txt file, but didn't see anything in the usercfg.txt file that was 'un-commented' for it to apply(???) I mean, I can see where you edited that to create a 'custom mode', but it is commented out, so would not have applied it or tried it... Just saying... That's what I see there.

    Recommends: Looking at your TV... As a best guess in probabilities, if it were me, I would probably use
    Code:
    hdmi_mode=1
    ## Set to      4096x2160     60Hz     256:135     Pi 4
    hdmi_mode=102
    Last edited by MAFoElffen; December 4th, 2021 at 08:23 AM.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  7. #7
    Join Date
    Apr 2008
    Beans
    20

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    I had the custom definition uncommented to match what it listed in the TV manual for a PC input:

    Code:
    hdmi_cvt=3840 2160 60 3 0 0 0    # Custom mode definition
    Is that a supported way of defining the mode, or do I need to use one of the standard mode sets?
    I also tried using these:

    Code:
    hdmi_group=2
    hdmi_mode= 96
    hdmi_mode= 97
    hdmi_mode= 98
    hdmi_mode= 99
    hdmi_mode= 100
    hdmi_mode= 101

  8. #8
    Join Date
    May 2010
    Beans
    3,366

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    Are you using Wayland or Xorg? If it's Xorg then you can make an xorg.conf and setup the display manually (old school)

  9. #9
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    @ActionParsnip:
    Talking FrameBuffer on Raspberry Pi(x)... I originally thought the same also,... Until i got one. Is sort of a different animal. There is no Grub, and it needs to set the video before it even gets to the Graphical Boot Manager (DM before DE). Wayland and XServer happens after that, so for this device, that is too late.

    They have text files that set the onboard chip initialization...

    @Yoodle...
    ??? Yes... But... In my instructions that came with my display, that is for Rasp Pi, Any custom modes, for example, the one suggested for my 13" portable 1920x1080 screen...
    Code:
    ### For this define, it uses mode 87, which is 1 above the defined modes...
    #### Custom mode define ####
    # hdmi_cvt=<width> <height> <framerate> <aspect> <margins> <interlace> <rb>
    # width        width in pixels
    # height       height in pixels
    # framerate    framerate in Hz
    # aspect       aspect ratio 1=4:3, 2=14:9, 3=16:9, 4=5:4, 5=16:10, 6=15:9
    # margins      0=margins disabled, 1=margins enabled
    # interlace    0=progressive, 1=interlaced
    # rb           0=normal, 1=reduced blanking
    ###
    hdmi_cvt=1920 1080 60 3 0 0 0    # Custom mode definition
    hdmi_group=2 
    hdmi_mode=87
    Note that this is documented in my usercfg.txt file that I had linked you to... That is from the manual on my display... The rest of the modes are from the Raspberry Pi Graphics documentation.

    Note that the Rasp Pi graphics documentation only has hdmi_group=2 going up to hdmi_mode=86 as presets... So When you define a custom mode, you set it to hdmi_mode=87, which is 'one above' the supported predefined modes...

    Which means, what you posted in the second half of post #7... none of those modes are predefined in hdmi_group=2... Those modes are predefined for hdmi_group=1. Is that what you meant? Or maybe you are just a bit confused how that works(?)

    Let me make a few examples to try to explain that better. Refere to my own usercfg.txt file that I posted here: https://ubuntuforums.org/showthread....9#post14055389

    Lets pick a mode that is one both hdmi_group's, lets say randomly, out of the blue 'mode 77'...
    Code:
    hdmi_group=1
    hdmi_mode=77
    Results in a preset mode resolution of 1080p 100Hz 64:27 on Pi 4...

    Whereas:
    Code:
    hdmi_group=2
    hdmi_mode=77
    Would be a preset of resolution 2560x1600 75Hz 16:10...

    So in your last post,
    Quote Originally Posted by Yoodle View Post
    Code:
    hdmi_group=2
    hdmi_mode= 96
    hdmi_mode= 97
    hdmi_mode= 98
    hdmi_mode= 99
    hdmi_mode= 100
    hdmi_mode= 101
    - anything from hdmi_group=2 and above hdmi_mode=86, is not predefined.
    - you have a spaces between the equals sign and the number. It looks for the first character after that equals sign, so as you had it, it would have failed, even if it had been a lower, valid mode number, just because there are extra spaces in there...
    - I know you probably had that written as an example, but if more than one line is uncommented, for the same variable name, then it takes whatever it the last assignment for that variable as the current value of.

    Now if you had used
    Code:
    hdmi_group=1
    hdmi_mode=96   # 2160p     50Hz     16:9     Pi 4
    # hdmi_mode=97   # 2160p     60Hz     16:9     Pi 4
    # hdmi_mode=98   # 4096x2160     24Hz     256:135     Pi 4
    # hdmi_mode=99   # 4096x2160     30Hz     256:135     Pi 4
    # hdmi_mode=100   # 4096x2160     50Hz     256:135     Pi 4
    # hdmi_mode=101   # 4096x2160     60Hz     256:135     Pi 4
    EDIT:
    Note that in the Raspberry Pi Doc's for Graphics, that
    Code:
    hdmi_group=1
    hdmi_mode=65
    ...says that mode preset is "CUSTOM"... But I have not been able to get an answer from 'anyone'. 'anywhere' to answer what that actually means.
    Last edited by MAFoElffen; December 4th, 2021 at 04:01 PM.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  10. #10
    Join Date
    Apr 2008
    Beans
    20

    Re: Ubuntu on Rapberry Pi won't display on large screen TV

    Quote Originally Posted by ActionParsnip View Post
    Are you using Wayland or Xorg? If it's Xorg then you can make an xorg.conf and setup the display manually (old school)
    I'm not sure which one I'm using, I just used the Raspberry Pi imager to create an SD card and booted, according to these instructions:
    https://ubuntu.com/tutorials/how-to-...i-4#1-overview

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •