Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

  1. #11
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Same problem with today's daily iso (20 Nov 2021).

    As bob-H says in the bug at https://bugs.launchpad.net/bugs/1951399 we seem to be trying hard but getting nowhere with this; if we can't install the OS how can we test it?

  2. #12
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    5,043
    Distro
    Kubuntu

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    only way we can test the os is to upgrade to it, is there a mini.iso? then we could just install the meta package to get as clean of a upgrade as possible
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  3. #13
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,085
    Distro
    Ubuntu Development Release

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    At this point all we can do is wait. At least the bug reports are more or less sorted out now, and finally realized to all be the same thing. If readers have not done so already, please click on "This bug affects me also" in the now main bug report to increase the heat. I won't even try the daily again until the date of the AMD64 file in the Ubuntu current directory becomes the date of the day I look. Since we know it is the same root issue for all flavours of Ubuntu, I suggest that others could do the same.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  4. #14
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Good idea and I shall be doing the same, though I will keep trying the live session to ensure that it runs well; I'll just not bother to attempt installing until the iso date matches the day of the install attempt.

  5. #15
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    1,228
    Distro
    Lubuntu Development Release

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    For those interested in the issue, refer Norbert's post on https://bugs.launchpad.net/ubuntu/+s...y/+bug/1951399

    https://bugs.launchpad.net/ubuntu/+s...99/comments/26

    A workaround is provided too; though if that's too much work; Lubuntu jammy still installs (as does Ubuntu Studio...)

    Sorry I couldn't help myself with the Lubuntu ref... (I'm a Lubuntu team member for those that didn't know...)

  6. #16
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Assuming I have the time I shall try Norbert's workaround later today.

    Thanks for pointing us in that direction; it's been difficult to keep up to date with this problem and all of the duplication across all of the different *buntu versions so this is very helpful.

    EDIT:

    Woowhooo!!!

    It worked fine installing today's (22 Nov 2021) iso of Xubuntu in KVM/QEMU in UEFI mode, so many thanks are due to Norbert for managing to figure that out.

    What we now need is a new iso build that contains the working version of debianutils or the old debianutils_4.11.2_amd64.deb in its place.
    Last edited by ajgreeny; 1 Week Ago at 09:23 PM.

  7. #17
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    It's fixed with today's "2021-11-24 08:32" ISO.

  8. #18
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Quote Originally Posted by VMC View Post
    It's fixed with today's "2021-11-24 08:32" ISO.
    But not for all the ISOs of the different DE versions.

    I have just zsynced today's iso of Xubuntu-jammy timed at 2021-11-24 02:14 and tried installing it using KVM/QEMU.

    Unlike today's Ubuntu iso mentioned above, the Xubuntu ISO still suffers with the crash when installation starts. I had assumed that all the daily ISOs would now be OK to install but apparently that's not yet the case.

  9. #19
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    5,043
    Distro
    Kubuntu

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Quote Originally Posted by ajgreeny View Post
    But not for all the ISOs of the different DE versions.

    I have just zsynced today's iso of Xubuntu-jammy timed at 2021-11-24 02:14 and tried installing it using KVM/QEMU.

    Unlike today's Ubuntu iso mentioned above, the Xubuntu ISO still suffers with the crash when installation starts. I had assumed that all the daily ISOs would now be OK to install but apparently that's not yet the case.
    from what i saw in the bug report, the xubuntu daily just missed the update for the fix when it was made
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  10. #20
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubiquity crashes when installing iso to bare metal, or as VM in KVM/QEMU

    Quote Originally Posted by pqwoerituytrueiwoq View Post
    from what i saw in the bug report, the xubuntu daily just missed the update for the fix when it was made
    Yes, I saw that on the bug site a short while ago so I'll zsync yesterday's ISO and try again later with today's.

    It sounds as if it has definitely been fixed at last!

    Huge thanks to all.

    EDIT

    Yes, it seems to be fixed now and I've installed Xubuntu 22.04 into a newly made partition in dual boot with my main 20.04 system.
    Working well at the moment but who knows how it will go between now and April next year.
    Time will tell.
    Last edited by ajgreeny; 6 Days Ago at 09:52 AM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •