Results 1 to 7 of 7

Thread: resolv and multiple search separator problem

  1. #1
    Join Date
    Nov 2021
    Beans
    6

    resolv and multiple search separator problem

    Hi,

    i'm strunggling with receiving multiple search suffixes.
    Receiving through DHCP or cloud-init, it does not matter: multiple suffixes end up wrong in resolv.conf

    I have multiple ".local" domains which i need to resolve. Unfortunately .local domains are mDNS and will be skipped by DNS @ 127.0.0.53 (multicast DNS on a server?)

    Receiving multiple domain searches ends up with "internal.local044mgmt.local044corp.local"

    Setting them manually using:
    sudo resolvectl domains eth0 internal.local mgmt.local corp.local
    makes it work but a netplan apply makes 044 come back through DHCP or cloud-init.

    Any idea which divider character can be used? , ; : <space> ?

  2. #2
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    7,731

    Re: resolv and multiple search separator problem

    I don't know, but if it's of any help, 044 is the octal for a dollar $ symbol, so I think that's where the 044 is coming from.

  3. #3
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: resolv and multiple search separator problem

    Setup a real DNS. It isn't THAT hard.
    Also consider using DHCP reservations for anything important - for non-laptop systems, it is smarter to use static IPs setup on-the-workstations/servers than to use DHCP reservations due to security failures https://www.anvilsecure.com/blog/dhc...r-devices.html in DHCP.

    When you do switch to using a local DNS, be certain to disable the caching DNS setup on your systems. Let the LAN DNS do that and reduce the points of failure.
    Laptops are harder, if they move around. I typically only have wifi use DHCP while the wired connection (using a USB3-to-GigE adapter) always uses a static IP.

  4. #4
    Join Date
    Nov 2021
    Beans
    6

    Re: resolv and multiple search separator problem

    Quote Originally Posted by TheFu View Post
    Setup a real DNS. It isn't THAT hard.
    Also consider using DHCP reservations for anything important - for non-laptop systems, it is smarter to use static IPs setup on-the-workstations/servers than to use DHCP reservations due to security failures https://www.anvilsecure.com/blog/dhc...r-devices.html in DHCP.

    When you do switch to using a local DNS, be certain to disable the caching DNS setup on your systems. Let the LAN DNS do that and reduce the points of failure.
    Laptops are harder, if they move around. I typically only have wifi use DHCP while the wired connection (using a USB3-to-GigE adapter) always uses a static IP.

    Yeah, i know.. i'm doing that manually now for about 20 years but the world evolves to.... (in my company) .. k8s.


    So i'm preparing for a orchestrated kubernetes environment where machines get spun up automatically through proxmox.
    Resolv.conf is acting the same when using manual ip settings through Cloud-init.

  5. #5
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: resolv and multiple search separator problem

    Well, use a devops tool (or any script you want) to fix it. mask any systemd-resolved stuff and purge resolvconf. Delete and replace /etc/resolv.conf to have what you want - pointing at the DNS server.

    I'd never trust mDNS.

  6. #6
    Join Date
    Nov 2021
    Beans
    6

    Re: resolv and multiple search separator problem

    Quote Originally Posted by TheFu View Post
    Well, use a devops tool (or any script you want) to fix it. mask any systemd-resolved stuff and purge resolvconf. Delete and replace /etc/resolv.conf to have what you want - pointing at the DNS server.

    I'd never trust mDNS.

    I guess you're right... this is probably not the place to argue why there's a mDNS implementation on a server.iso


    Could i also create my own cloud-init image with a suiteable DNS client? One that interprets multiple search suffixes through DHCP (or cloud-init)?
    Any advice on this direction?

  7. #7
    Join Date
    Nov 2021
    Beans
    6

    Re: resolv and multiple search separator problem

    It feels there is a problem with proxmox "use the host-settings" for cloud-init values.
    Whenever setting the value "per VM", it works (with manual IP).

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •