Results 1 to 2 of 2

Thread: azerty keyboard not recognized on VM

  1. #1
    Join Date
    Oct 2021
    Beans
    1

    Question azerty keyboard not recognized on VM

    Hi everyone,
    New user here.

    I'm running Ubuntu 20.04 on a desktop and same on a Google Cloud VM.
    My azerty (Belgian) keyboard works fine on my desktop, but I'm having some issues in the VM: With the exact same language, formati and kb setting as my desktop, the VM does not want to accept the azerty layout. When I have the azerty layout (be wang) selected in the VM and open the on screen keyboard, the keys don't match. So I'm pressing 'a' (first letter top left on my physical keyboard) and the on-screen keyboard indicated that 'q' (first letter second row) is pressed.

    I'm now using the US layout in querty since most letters in reverse from the azerty layout, but this is driving me insane because the special characters do not match.
    I've tried with another keyboard and it's the exact same result. OK on the desktop, but in the VM (via the desktop) it doesn't work.

    settings:
    XKBLAYOUT=be
    XKBVARIANT=wang
    BACKSPACE=guess

    Does any of you have any idea what's going on and how to fix this?
    Thanks,
    Ivan

  2. #2
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    906
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: azerty keyboard not recognized on VM

    You probably need to install the keyboard layout in your VM first. Otherwise it always defaults to US no matter what you try to select.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •