Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Grub 2 Its working but every second boot .....

  1. #1
    Join Date
    Oct 2021
    Beans
    8

    Question Grub 2 Its working but every second boot .....

    All,
    I am a convert from the Windows (ewwww) domain and I have been using Linux for about a year.

    I have a quadruple boot set up with:
    Windows 10
    Linux Mint 20.2
    Zorin 16
    elementary OS 6

    All functioning and all menu items in grub work.

    But about every second boot (first run or restart from another distro) I get the Grub stock menu instead of my proper menu.

    "GNU GRUB Menu 2.0.4
    Minimal Bash like line editing is supported
    blah blah blah

    grub>"

    If I type "exit" at the grub prompt it takes me to my menu?!?!?!?!?

    Anybody seen this before or know how to fix it???

    I have added my grub.cfg file (Grub 2.04) if that helps.

    I cant see any errors in the script......

    Any help would be appreciated. It's not the end of the world but damn aggravating.....

    Thanks in advance

    Znamloot
    Attached Files Attached Files

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub 2 Its working but every second boot .....

    Moved to Mint sub-forum, since not official flavor of Ubuntu.

    I actually just had that.
    But after booting checked all my settings & reinstalled grub.
    I have main working install of Kubuntu 20.04, but install each release as a test or reinstall to experiment with settings.
    Those installs overwrite my main installs UEFI & /EFI/ubuntu settings & I have to revert them. I used to backup ESP (still do), but found manually editing settings or just total reinstall of grub to be easier.
    Sometime UEFI goes to an install that no longer exist as I have not yet housecleaned or installed over an old one changing GUIDs & UUIDs.

    Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO:
    Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed.
    https://help.ubuntu.com/community/Boot-Repair
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    ok ran the boot-info summary report. (I had no idea it was available as a downloadable program - thx)
    Link:
    https://paste2.org/

    I await you verdict - thanks
    Znamloot

  4. #4
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    A quick note on this process. I ran the boot-repair boot-info summary report and directly uploaded it to https://paste2.org/ but how do you tell where it is?

    Sorry, full of questions today.

    Thanks again

    Znamloot

  5. #5
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Grub 2 Its working but every second boot .....

    Please use the pastebin link you get in the boot-info report, not the one you have now tried twice without success.

  6. #6
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    I have been through this several times and this is the "boot repair" screen after uploading to pastebin:




    There is no link..... at least in the above screen. Is it somewhere else?

    Really lost here - let me go back to the documentation.

    https://help.ubuntu.com/community/Boot-Info

    This screen looks nothing like the ones in the above link ....

    Maybe I'll try the boot info ISO and see if that works.

    Cheers

    Znamloot

  7. #7
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    Here's the screen - copy and paste doesn't work on this forum.
    Attached Images Attached Images

  8. #8
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    Ok I got it to work from the boot-repair-disk-64bit.iso when I rebooted:

    The link is as follows:

    http://paste.ubuntu.com/p/7r59QNk9hT

    I hope I got it right.....

    tested and it works.....

  9. #9
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    I also ran it on Zorin 16 but got a different result - this time it shows up on the screen!

    The link is:

    https://paste.ubuntu.com/p/J98CNXxyvQ/

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub 2 Its working but every second boot .....

    You have UEFI system, gpt partitioned drives & UEFI boot of every system.
    But you have an old BIOS boot of Windows in nvme1n1. Not sure how you would have that as Windows only boots in UEFI mode from gpt drives.

    But you ran Boot Repair in old BIOS/CSM/Legacy mode. Since UEFI system with UEFI installs, you never should boot in BIOS mode. That may try to do a BIOS type repair can cause further issues.
    The current session is in BIOS-compatibility mode.
    Do not really know grub-customizer. It replaces grub scripts with its own proxy scripts.
    Those with multiple installs & using grub would normally be better using grub and modifying it if desired.

    Since not showing UEFI boot entries cannot tell if that is part of issue. It could just be UEFI set to boot an install that is not working, so then it boots second in UEFI boot menu. Or is trying to boot Windows BIOS boot loader, fails & then boots a valid entry.

    Post this from UEFI boot in code tags to preserve formatting. Use # icon in Forum Go Advanced editor.
    sudo efibootmgr -v
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •