Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Grub 2 Its working but every second boot .....

  1. #11
    Join Date
    Oct 2021
    Beans
    8

    Re: Grub 2 Its working but every second boot .....

    This is it I hope (I am learning quite a bit with this):

    sudo efibootmgr -v

    Code:
    BootCurrent: 0000
    Timeout: 1 seconds
    BootOrder: 0000,000D,0002,0001,000C,000E,000F,0010
    Boot0000* ubuntu        HD(2,GPT,8e6b545c-1fa2-42a0-d5a7-31f8eefaf8ba,0xfa000,0x31800)/File(\EFI\UBUNTU\SHIMX64.EFI)
    Boot0001* elementary OS 6 Odin  HD(1,GPT,838c823f-7454-469b-881b-6209caba2e0b,0x1000,0x838f7)/File(\EFI\UBUNTU\SHIMX64.EFI)
    Boot0002* Windows Boot Manager  HD(2,GPT,8e6b545c-1fa2-42a0-d5a7-31f8eefaf8ba,0xfa000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.
    a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
    Boot000C* Hard Drive    BBS(HD,,0x0)..GO..NO........q.S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .5.0.0.G.B....................A...........................%8\..&......4..Gd-.;.A..MQ..L.S.4.6.6.N.X.0.K.C.2.8.3.5.9.H...
    .....BO..NO........o.S.T.3.0.0.0.D.M.0.0.8.-.2.D.M.1.6.6....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .5.Z.5.0.V.F.F.Q........BO..NO........o.C.T.5.0.0.M.X.5.0.0.S.S.D.1.
    ...................A...........................>..Gd-.;.A..MQ..L.9.1.9.0.1.E.D.E.6.2.D.F. . . . . . . . ........BO
    Boot000D* ubuntu        HD(1,GPT,9c538813-d40e-421f-855e-d3aedcf56afa,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)..BO
    Boot000E* UEFI: SMI USB DISK 1100, Partition 1  PciRoot(0x0)/Pci(0x14,0x0)/USB(24,0)/USB(1,0)/HD(1,MBR,0x38812088,0x800,0xe77800)..BO
    Boot000F* UEFI: SMI USB DISK 1100, Partition 2  PciRoot(0x0)/Pci(0x14,0x0)/USB(24,0)/USB(1,0)/HD(2,MBR,0x38812088,0xe78000,0x10000)..BO
    Boot0010* USB   BBS(HD,,0x0)..GO..NO........i.S.M.I. .U.S.B. .D.I.S.K. .1.1.0.0....................A.............................6..Gd-.;.A..MQ..L.C.C.Y.Y.M.M.D.D.L.U.Y.N.G.G.C.V........BO
    The last 2 uploads of boot-info were created in my Zorin 16 OS if that makes a difference.....


    The boot-info app doesn't give me the pastebin url .... don't know why....


    Thanks again

    Cheers

    Znamloot

  2. #12
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub 2 Its working but every second boot .....

    Zorin just may not have something Boot-Repair needs to upload. Or is Internet not working.

    You show three FAT32 partition, one specifically labeled as ESP, but label does not matter, its whether is has esp,boot flags so UEFI can see it as an ESP. Report shows all three with esp flags.
    You show three different ESP used for UEFI boot entries. I expect Mint uses an Ubuntu entry even though not an official flavor of Ubuntu.

    I do like to have an ESP on different drives, but Ubuntu makes it difficult to use that. Other distributions let you set which ESP to use during install.

    First in Boot Order is 0000 an Ubuntu entry use the partUUID of nvme0n1p2 .
    Second is 000D an Ubuntu entry using nvme1n1p1.

    The grub.cfg in nvme0n1p1 has this which has correct UUID, but shows msdos1 and you only have gpt partitions.
    I might just edit msdos to gpt and then see if it works.
    search.fs_uuid 99149bfc-4662-45ec-b682-552cf640f5ca root hd2,msdos1

    You can see that comparing GUID/partUUID entries in efibootmgr & lsblk which also are in the report.
    sudo efibootmgr -v
    lsblk -e 7 -o name,fstype,size,fsused,label,partlabel,mountpoint ,uuid,partuuid
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •