Results 1 to 3 of 3

Thread: Bluetooth on Lenovo IdeaPad 3 is disabled on boot by default.

  1. #1
    Join Date
    Feb 2007
    Location
    St. Louis, MO
    Beans
    4,930
    Distro
    Ubuntu 20.04 Focal Fossa

    Bluetooth on Lenovo IdeaPad 3 is disabled on boot by default.

    I recently purchased a new Lenovo IdeaPad 3 with Ryzen 7 5700U, Radeon graphics, NVME, etc.

    All works well running Linux Mint 20.2 using the 5.11.0-37 kernel (had to use it as some devices didn't work properly like screen brightness control).

    When I pair my Bluetooth mouse (it paired no problem), I have to turn on the Bluetooth using the icon in the system tray. I have checked the following.

    /etc/bluetooth/main.conf and AutoEnable = true

    I them tried:

    sudo systemctl is-enabled bluetooth

    this command returns enabled


    I was able to effect that Bluetooth will be enabled when I log i. I created a startup with the following:

    Code:
    rfkill unblock bluetooth
    This results in bluetooth being enabled after I log in, can I use the same command in GRUB?


    My question is, are there any grub or BIOS settings that can help?

    Thanks.
    Windows, only good for gaming.

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    9,617
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Bluetooth on Lenovo IdeaPad 3 is disabled on boot by default.

    Moved to Mint

  3. #3
    Join Date
    Feb 2007
    Location
    St. Louis, MO
    Beans
    4,930
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Bluetooth on Lenovo IdeaPad 3 is disabled on boot by default.

    I did a little more research and was able to create a service using systemd. This allowed the rfkill command to be executed during the boot process and paired the mouse sooner.

    I will mark the thread solved.
    Windows, only good for gaming.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •