Results 1 to 7 of 7

Thread: Mouse stopped working after system lockup

  1. #1
    Join Date
    Apr 2008
    Location
    So. Cal., USA
    Beans
    54
    Distro
    Xubuntu 16.04 Xenial Xerus

    Mouse stopped working after system lockup

    Yesterday, my desktop computer, running Xubuntu, froze and I had to kill the power to get it to reboot. Now, my USB mouse doesn't work on any port, although it works on a different computer and other things work through USB. I've tried a different mouse with the same results and power cycling to reboot doesn't help.. I'm not sure which version of Xubuntu I have and don't know how to find out without a mouse. Please give me simple instructions for finding out which version I have and getting my mouse working again.

  2. #2
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,596
    Distro
    Xubuntu

    Re: Mouse stopped working after system lockup

    Have you tried a wired mouse? Do you have an external HD that you can plug in and see if it spins up? I am thinking that you lost the 5 volt output of your power supply.

  3. #3
    Join Date
    Apr 2008
    Location
    So. Cal., USA
    Beans
    54
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Mouse stopped working after system lockup

    All of the mice I've tried have been wired.

  4. #4
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,596
    Distro
    Xubuntu

    Re: Mouse stopped working after system lockup

    OK. But that does not tell us whether or not you have lost the 5V signal from the power supply. My guess is that either you have a failed or failing power supply, or something else on the PC (hard drive, USB hub, printer) is pulling the 5v too low. IF you are using any USB hubs: powered or nonpowered, disconnect them. Disconnect EVERY USB peripheral including the receiver for the mouse and try a wired mouse. You should also try another keyboard. See what happens and report back!

  5. #5
    Join Date
    Apr 2008
    Location
    So. Cal., USA
    Beans
    54
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Mouse stopped working after system lockup

    I don't have a USB hub on that computer, but I've tried every port possible with two different mice. I may well need to buy a hub, as it's cheaper than taking it into the shop. And, there is no "receiver" for a mouse because I already wrote that I don't have a wireless mouse.

  6. #6
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,596
    Distro
    Xubuntu

    Re: Mouse stopped working after system lockup

    With the mouse plugged in, does at least the red laser light come on under the mouse?

    Do you have a USB or DVD that you can boot the PC from to see if the mouse then works?

  7. #7
    Join Date
    Apr 2008
    Location
    So. Cal., USA
    Beans
    54
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Mouse stopped working after system lockup

    Not with the original mouse. I'm not sure if it does with a different mouse and I can't test it right now. Will check it later and let you know.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •