Results 1 to 2 of 2

Thread: DockingStation keeps disconnecting on reboot

  1. #1
    Join Date
    Oct 2021

    DockingStation keeps disconnecting on reboot


    I have a docking station (link below) which is working fine in Windows. Recently because my laptop's performance is not great in Windows (Thinkpad P15) I am testing some Linux distros.

    My problem is with the docking station, it's an Anker usb 3. It works fine and after installing the driver the external HDMI display works as well. But everytime I reboot from Linux and boot to either Linux or Windows, the Docking statoin doesn't work anymore, unless I pull the power plug out and plug it in again. This never happens if I restart from Windows to either os.

    I have tried several distors, Ubuntu, Mint, PopOs, WindowsFx, Fedora, and many others (I am a newbie though with Linux) they all have this problem and it is consistent, happens every single time.

    I am now tryting to confirm if I buy a new docking station this problem would be sorted, or is it something generally with linux?

    Thank you all.

  2. #2
    Join Date
    Mar 2011
    Ubuntu 20.04 Focal Fossa

    Re: DockingStation keeps disconnecting on reboot

    Have you tried a USB 3 port near your motherboard (i.e. at the back?). I am running Ubuntu 20.04 now on both USB 3.0 and USB 2.0 to several docking stations and old drives in container. Port switching might help.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts