Results 1 to 2 of 2

Thread: set enviroment variable to metasploit

  1. #1
    Join Date
    Sep 2021
    Beans
    1

    set enviroment variable to metasploit

    hello i have the following question. i want to create a connection between metasploit and the tool TheFatRat. although i have both programs installed the program can't find the access to metasploit. i think i have to set an environment variable. but i don't know how




    #daniel@da-m82:~/TheFatRat$ sudo ./chk_tools
    --------- TheFatRat tools version check----------
    ---- ---------------------------------------------
    * - Checking Netcat (Net Check)...............[✔]
    * - Checking Xterm (Terminal).................[✔]
    * - Checking Dig (Dns-Util)...................[✔]
    * - Checking mono-mcs (compiler)..............[✔]
    * - Checking Gcc (compiler)...................[✔]
    * - Checking Apache2 (Web Server).............[✔]
    * - Checking Gnome Terminal (Terminal)........[✔]
    * - Checking Upx (File Compressor)............[✔]
    * - Checking Ruby (Programming)...............[✔]
    * - Checking Gem (Ruby modules installer).....[✔]
    * - Checking nokogiri (Ruby module)...........Error loading RubyGems plugin "/var/lib/gems/2.7.0/plugins/yard_plugin.rb": cannot load such file -- /tmp/bundler20210924-25520-loag3tyard-0.9.26/gems/yard-0.9.26/lib/rubygems_plugin.rb (LoadError)
    [✔]
    * - Checking Openssl (Certificates)...........[✔]
    * - Checking Python3 (Programming)............[✔]
    * - Checking Python-pip3 (Module Installer)...[✔]
    * - Checking names (python module)............[✔]
    * - Checking Build-Essential (Cross Compiler).[✔]
    * - Checking Python-Dev (Compiler)............[✔]
    * - Checking lib32z1 (apk Req.)...............[✔]
    * - Checking lib32ncurses5 (apk Req.).........[✔]
    * - Checking lib32stdc++6 (apk Req.)..........[✔]
    * - Checking Jarsigner (apk Req.).............[✔]
    * - Checking Keytool (apk Req.)...............[✔]
    * - Checking Unzip (Unpacker).................[✔]
    * - Checking Zipalign (Apk Req.)..............[✔]
    * - Checking Mingw 64 Bit (Compiler)..........[x] Not Found


    ------------Solution -------------
    Step 1 - Run Setup from fatrat

    chmod +x setup.sh && ./setup.sh

    ----------------------------------
    * - Checking Mingw 32 Bit (Compiler)..........[x] Not Found

    ------------Solution -------------
    Step 1 - Run setup from fatrat

    chmod +x setup.sh && ./setup.sh
    ----------------------------------


    * - Checking Dx (Apk Req.)....................[✔]
    * - Checking Aapt (Apk Req.)..................[✔]
    * - Checking Apktool (Apk Req.)...............[✔]
    * - Checking Baksmali (Apk Req.)..............[✔]
    * - Checking Metasploit-Framework (msfc)......[x] Solution: apt-get install metasploit-framework
    Install using kali repository
    * - Checking Metasploit-Framework (msfv)......[x] Solution: apt-get install metasploit-framework
    Install using kali repository
    * - Checking Backdoor Factory (exe backdoor)..[✔]
    * - Checking Searchsploit (exploit db)........[x] Solution: apt-get install exploitdb
    Install using kali repository/Ignore in case manually installed #



  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: set enviroment variable to metasploit

    From TheFatRat github page:

    TheFatRat is an exploiting tool which compiles a malware with famous payload, and then the compiled maware can be executed on Linux , Windows , Mac and Android. TheFatRat Provides An Easy way to create Backdoors and Payload which can bypass most anti-virus.
    Really?

    Thread closed.
    Ubuntu 18.04 Desktop Guide - Ubuntu 20.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    If you need help with your forum account, such as SSO login issues, username changes, etc, the correct place to contact an admin is here. Please do not PM me about these matters unless you have been asked to - unsolicited PMs concerning forum accounts will be ignored.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •