Results 1 to 6 of 6

Thread: Wireless not showing after installing Additional Drivers deb

  1. #1
    Join Date
    Sep 2021
    Beans
    3

    Wireless not showing after installing Additional Drivers deb

    Not sure if installing Additional Drivers deb is actually the issue, but this is the only thing I could think of that I have changed since the last restart. This said, now, I do don't even see network in notification area, but can open it via settings. This is what I get in console:

    Code:
    milos@lenovo:~$ sudo lshw -C network  *-network                 
           description: Ethernet interface
           product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: enp2s0
           version: 10
           serial: 98:fa:9b:34:15:d7
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-34-generic firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:16 ioport:3000(size=256) memory:b4204000-b4204fff memory:b4200000-b4203fff
      *-network
           description: Network controller
           product: QCA9377 802.11ac Wireless Network Adapter
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:03:00.0
           version: 31
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: driver=ath10k_pci latency=0
           resources: irq:135 memory:b4000000-b41fffff
      *-network:0
           description: Ethernet interface
           physical id: 3
           logical name: veth5a51ebf
           serial: e6:cb:96:b9:5e:9e
           size: 10Gbit/s
           capabilities: ethernet physical
           configuration: autonegotiation=off broadcast=yes driver=veth driverversion=1.0 duplex=full link=yes multicast=yes port=twisted pair speed=10Gbit/s
      *-network:1
           description: Ethernet interface
           physical id: 4
           bus info: usb@1:3
           logical name: usb0
           serial: 86:89:4b:ea:5e:03
           capabilities: ethernet physical
           configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-34-generic firmware=RNDIS device ip=192.168.42.201 link=yes multicast=yes
    So, the only problem that I have right now is that WiFi is not working.


    UPDATE: However, a slightly different output without sudo:

    Code:
    milos@lenovo:~$ sudo lshw -class network  *-network                 
           description: Ethernet interface
           product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: enp2s0
           version: 10
           serial: 98:fa:9b:34:15:d7
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-34-generic firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:16 ioport:3000(size=256) memory:b4204000-b4204fff memory:b4200000-b4203fff
      *-network
           description: Network controller
           product: QCA9377 802.11ac Wireless Network Adapter
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:03:00.0
           version: 31
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: driver=ath10k_pci latency=0
           resources: irq:135 memory:b4000000-b41fffff
      *-network:0
           description: Ethernet interface
           physical id: 3
           logical name: veth5a51ebf
           serial: e6:cb:96:b9:5e:9e
           size: 10Gbit/s
           capabilities: ethernet physical
           configuration: autonegotiation=off broadcast=yes driver=veth driverversion=1.0 duplex=full link=yes multicast=yes port=twisted pair speed=10Gbit/s
      *-network:1
           description: Ethernet interface
           physical id: 4
           bus info: usb@1:3
           logical name: usb0
           serial: 86:89:4b:ea:5e:03
           capabilities: ethernet physical
           configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-34-generic firmware=RNDIS device ip=192.168.42.201 link=yes multicast=yes
    Last edited by errorous; September 14th, 2021 at 01:35 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,643
    Distro
    Ubuntu Development Release

    Re: Wireless not showing after installing Additional Drivers deb

    Please run and post:

    Code:
    sudo dmesg | grep -i ath
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Sep 2021
    Beans
    3

    Re: Wireless not showing after installing Additional Drivers deb

    Empty, no output.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,643
    Distro
    Ubuntu Development Release

    Re: Wireless not showing after installing Additional Drivers deb

    Let's try another approach:

    Code:
    sudo modprobe ath10k_pci
    sudo dmeg | grep ath
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #5
    Join Date
    Sep 2021
    Beans
    3

    Re: Wireless not showing after installing Additional Drivers deb

    Code:
    milos@lenovo:~$ sudo modprobe ath10k_pci
    milos@lenovo:~$ sudo dmesg | grep ath
    milos@lenovo:~$

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,643
    Distro
    Ubuntu Development Release

    Re: Wireless not showing after installing Additional Drivers deb

    Let's see what is going on, or wrong, on the PCI bus:

    Code:
    sudo dmesg | grep 03:00
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •