Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: when installing Geant4 with multi-threading , gives the eror of something of linux ?

  1. #1
    Join Date
    Sep 2021
    Beans
    7

    when installing Geant4 with multi-threading , gives the eror of something of linux ?

    Hi Experts,

    I was installing Geant4 software in my system (Ubuntu 18 )with using multi-threading but getting the below error. i am not getting this why i am facing this problem.
    i have asked on Geant4 forum if it was the Geant problem but they were suggesting to ask here.
    so can anyone please help me with this. it will be very helpful.
    waiting for a reply!
    Thanks & Regards
    Priyanshu
    [IMG]scp IMG_20210907_150828209.jpg priyanshu@ubuntuforums.org[/IMG]
    Attached Images Attached Images
    Last edited by priyanshu-agrawal; September 7th, 2021 at 05:45 PM.

  2. #2
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    6,032
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    /usr/lib/x86_64-linux-gnu/libGL.so is provided on 18.04 by the packages libglvnd-dev (vendor neutral) and nvidia-340, for those who need that nvidia driver. You need the file (actually a symlink, I presume) to compile software using openGL. On my 21.04 system the symlink is in the package libgl-dev, which in 18.04 is a virtual package provided by libgl1-mesa-dev, which in turn pulls in libglvnd-dev, which is the actual package you need.

    I suggest you install libgl1-mesa-dev. Use your favourite package management tool. If you want the terminal, use
    Code:
    sudo apt install libgl1-mesa-dev

  3. #3
    Join Date
    Sep 2021
    Beans
    7

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    Thank you very much for you reply!
    i have done this, this is showing me this.what does that mean , i didn't understand as i am new to this OS.
    can you please tell what should i do now ?

    Thanks in advance!
    Priyanshu
    Attached Images Attached Images
    Last edited by QIII; September 8th, 2021 at 08:50 AM. Reason: removed large images

  4. #4
    Join Date
    Sep 2021
    Beans
    7

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    so sorry, i have uploaded wrong images.
    and i am not getting how can i remove those.
    attaching new one for which i was taking about.
    Attached Images Attached Images

  5. #5
    Join Date
    Sep 2021
    Beans
    7

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    now, again trying to install with multi-threading then it is again the same problem occurring why so , really i am not getting this.
    please see the attachment below.
    Attached Images Attached Images

  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    Hello!

    Please do not embed large images. Some of our users have slow connections and some pay for data. Large images may load slowly or even cost users money.

    Also, please enclose all terminal commands and results in code tags rather that taking a screenshot.

    To use code tags:

    1. If you are using the "Reply to Thread" button, please type or paste your text, highlight the text and use the # button in the text box header. Alternatively, click the # button first, place your cursor between the code tags and type or paste your text.

    2. If using "Quick Reply" then type [code] at the beginning and [/code] at the end. The square brackets are required.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    Sep 2021
    Beans
    7

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    now, again trying to install with multi-threading then it is again the same problem occurring why so , really i am not getting this.
    please see the attachment below.

  8. #8
    Join Date
    Aug 2013
    Beans
    4,714

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    On my system (Ubuntu20.04)
    Code:
    $dpkg -S /usr/lib/x86_64-linux-gnu/libGL.so
    libgl-dev:amd64: /usr/lib/x86_64-linux-gnu/libGL.so
    So you need to install libgl-dev
    Code:
    sudo apt install libgl-dev

  9. #9
    Join Date
    Aug 2013
    Beans
    4,714

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    Looks like you don't need to build it from source, there is a ppa for geant4. So just add it to your sources list and install it like any package
    Code:
    sudo add-apt-repository ppa:kaktusjoe/g4dist
    sudo apt update
    sudo apt install geant4

  10. #10
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    6,032
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: when installing Geant4 with multi-threading , gives the eror of something of linu

    Quote Originally Posted by monkeybrain20122 View Post
    On my system (Ubuntu20.04)
    Code:
    $dpkg -S /usr/lib/x86_64-linux-gnu/libGL.so
    libgl-dev:amd64: /usr/lib/x86_64-linux-gnu/libGL.so
    So you need to install libgl-dev
    Code:
    sudo apt install libgl-dev
    Yes, but it apears to be somewhat different on 18.04.

    Quote Originally Posted by monkeybrain20122 View Post
    Looks like you don't need to build it from source, there is a ppa for geant4. So just add it to your sources list and install it like any package
    Code:
    sudo add-apt-repository ppa:kaktusjoe/g4dist
    sudo apt update
    sudo apt install geant4
    A PPA is definitely easier than installing from source, even for people who are not new to Ubuntu. Installing from source is a last resort. So I suggest you try the PPA. If that doesn't work, we can look further.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •