Results 1 to 3 of 3

Thread: Issue with Samba client

  1. #1
    Join Date
    Dec 2020
    Beans
    21

    Issue with Samba client

    Hi,
    I followed the steps below
    https://kifarunix.com/install-and-co...-ubuntu-20-04/


    to create shared path on Ubunto 20.04 but after that, I also grant right to the client IP like


    ufw allow from 10.0.2.15/24 to any app Samba


    to access Samba remotely. But on Windows client, I cannot access it expectedly.

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Issue with Samba client

    Why not follow the instructions at help.ubuntu.com? Just curious. Following instructions from random sites is a way to get incomplete answers or answers for the wrong distribution.

    Can your Win10 client ping the Ubuntu system by IP? by name?

  3. #3
    Join Date
    Dec 2009
    Beans
    6,569

    Re: Issue with Samba client

    ufw allow from 10.0.2.15/24 to any app Samba
    I don't know much about ufw but I suspect the problem is you are specifying a IPv4 range of addresses. Windows 10 makes it's initial contact with the server using an IPv6 address so the way you are set up it will automatically be denied access even if it has an IPv4 address in that range.

    The closest thing I have done personally to this situation is used the "hosts allow" parameter in smb.conf. If I set it to a range of IPv4 addresses Win10 is denied access. But if I set this up to a range of IPv6 address it works.

    I run this command to find my ip address on the server:
    Code:
    hostname -I
    For example:
    ~$ hostname -I
    192.168.1.137 2605:a601:a18d:9f00:a00:27ff:fe16:7607
    So in my example I would set "hosts allow" to:
    Code:
    hosts allow = 2605:a601:a18d:9f00::/64
    See if ufw can handle IPv6 this way.
    Last edited by Morbius1; September 2nd, 2021 at 12:27 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •