Results 1 to 6 of 6

Thread: Unable to install php5.6-fpm on Ubuntu 16.04

  1. #1
    Join Date
    Aug 2021
    Beans
    2

    Unable to install php5.6-fpm on Ubuntu 16.04

    Hello All,

    We are trying to install php5.6-fpm on Ubuntu 16.04 server but we unable to install. We are following the below steps to install.

    sudo apt-get install python-software-properties
    sudo add-apt-repository ppandrej/php
    sudo apt-get update

    sudo apt-get install -y php5.6

    Error while installing:-
    $apt-get install php5.6-fpm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package php5.6-fpm
    E: Couldn't find any package by glob 'php5.6-fpm'
    E: Couldn't find any package by regex 'php5.6-fpm'

    Can someone help me with the possible solution to install php 5.6-fpm

  2. #2
    Join Date
    Feb 2010
    Location
    Obscurial Springs
    Beans
    14,826
    Distro
    Ubuntu Budgie Development Release

    Re: Unable to install php5.6-fpm on Ubuntu 16.04

    16.04 reached end of life in April unless you have Extend Maintenance Security. That may explain why the package is not found.
    https://ubuntu.com/security/esm
    "Our intention creates our reality. "

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  3. #3
    Join Date
    Aug 2021
    Beans
    2

    Re: Unable to install php5.6-fpm on Ubuntu 16.04

    Hello Frogs,

    Thanks for the update. We are using Ubuntu 16.04 in Azure from Canonical publisher which comes with Extended Maintenance Security. Is there anything to be done to get php5.6-fpm to be installed.

  4. #4
    Join Date
    Feb 2010
    Location
    Obscurial Springs
    Beans
    14,826
    Distro
    Ubuntu Budgie Development Release

    Re: Unable to install php5.6-fpm on Ubuntu 16.04

    Quote Originally Posted by kumar3314 View Post
    Hello Frogs,

    Thanks for the update. We are using Ubuntu 16.04 in Azure from Canonical publisher which comes with Extended Maintenance Security. Is there anything to be done to get php5.6-fpm to be installed.
    I can't tell you tell you what package repositories other than security are available with EMS. The Ubuntu old repositories are available, but mainly for distribution upgrade purposes.
    "Our intention creates our reality. "

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  5. #5
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Unable to install php5.6-fpm on Ubuntu 16.04

    Thread moved to Server Platforms.

  6. #6
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Unable to install php5.6-fpm on Ubuntu 16.04

    LOL

    You need to add this PPA . He does have a note about end-of release Ubuntu, but worth a try. He is the main maintainer for the PHP packages...
    Code:
    sudo add-apt-repository ppa:ondrej/php
    sudo apt-get update
    sudo apt-get install php5.6-fpm
    Enjoy...
    Last edited by MAFoElffen; August 25th, 2021 at 02:37 AM.

    Concurrent coexistance of Windows, Linux and UNIX...
    Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    UbuntuForums system-info Script

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •