Results 1 to 2 of 2

Thread: 20.04 Desktop GUI won't open.

  1. #1
    Join Date
    Mar 2007
    Beans
    1,131

    20.04 Desktop GUI won't open.

    I have a desktop machine running 20.04 which has been working well for several months, since I upgraded it.
    the other day after I rebooted it it failed to start the GUI.

    It seems to be booting normally the Ubuntu flash screen is showing but after a while the screen flashes and goes dark, no input is accepted, although the Caps Lock and Num Lock and Scroll Lock keys all light the appropriate lights. Ctrl Alt Delete causes a reboot. I'm pretty sure the O/S is running but the Graphics is trashed. Unfortunately I'm still able to change sessions and get to a command prompt log in but can't enter anything. I can't do a remote login, ssh fails. I can get to a Grub menu going to the recovery option or booting an alternate kernel does not reveal anything. If I abort the flash screen during boot I can observer the scroll and notices the following:

    After the gdm.service starts a few more things scroll by and the screen goes blank.

    I get the following errors during boot ( I may not have transcribed them exactly, they go by pretty fast.

    Code:
    radeon 
         no UMS support in Radeon module
    The graphics on the motherboard is Radeon HD 4250
    Later I get this error
    Code:
    uvcvideo failed to query (GET_DEF) UVC control2 on Unit 1
    Most of the references to this error I've found to this refer to a webcam. I do have a webcam on the computer, removing it resolved the error.

    Ok I was finally able to get a working command prompt, I don't know exactly what I did different. But I was able to run

    Code:
    dpkg --configure -a
    which ran clean and
    Code:
    dpkg-reconfigure lightdm
    to change the display manager to lightdm that gave me a login prompt but I couldn't login.
    Changed dm back to gdm3 and the original problem reappeared.

    I think I've solved it.
    Apparently an external drive used for backups failed to mount and the cron job filled the root partition to the extent that the GUI wouldn't completely load.
    After removing the extra data everything seems to have returned to normal.
    BTW the root partition had about 3GB of space remaining. I am surprised that isn't enough. I used to run whole workstations with less than that amount to disk space.
    I'll look at some methods from preventing a recurrence.
    I'll monitor it for a while and mark this as solved if to doesn't repeat.

  2. #2
    Join Date
    Mar 2007
    Beans
    1,131

    Re: 20.04 Desktop GUI won't open.

    Looks like it's solved. 24 hours and not repeat. I'm marking this thread solved.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •