Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Disable display power management for Lubuntu 20.04 LTS / LXQt

  1. #1
    Join Date
    Mar 2021
    Beans
    19

    Disable display power management for Lubuntu 20.04 LTS / LXQt

    I'm trying to use Lubuntu 20.04 LTS / LXQt for a digital signage application. It seems Lubuntu disables display output after 5-10 minutes. The physical display shows "no signal detected" when this happens, but I can still ssh to the system. When the system boots, a user is automatically signed on and the signage software client launches. For this user/account, I've tried:


    • Editing ~/.xscreensaver and changing timeout from 0:10:00 to 24:00:00
    • Creating ~/.xinitrc and adding the lines:
      • xset s off
      • xset -dpms


    I rebooted after making these changes. These changes made no difference. I'm guessing I may need to adjust a global setting, perhaps something in /etc/sddm.conf...?

    I would appreciate your hints/suggestions!

  2. #2
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    875
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Try Preferences -> LXQt Settings -> Power Management, select Idle and uncheck the Enable box.

    Leave the SDDM stuff alone, that's only for the login screen.

  3. #3
    Join Date
    Mar 2021
    Beans
    19

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Yeah, that was already unchecked...

  4. #4
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    1,162
    Distro
    Lubuntu Development Release

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    I've had no issues, but I've only used GUI tools to make changes so I don't know if you've missed anything with your direct edits

    For screensaver look at https://manual.lubuntu.me/lts/3/3.2/...reensaver.html

    For power settings look at https://manual.lubuntu.me/lts/3/3.2/...anagement.html

    I don't have experience (recent anyway) with your changes so cannot comment on what you're missing; but not having a screen blank is quick & easy to achieve via settings in the manual (it's QA-tested semi-regularly each cycle)
    Last edited by guiverc; September 8th, 2021 at 01:57 AM.

  5. #5
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    875
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Quote Originally Posted by Regexaurus View Post
    Yeah, that was already unchecked...
    Good.
    Next try is: Preferences -> LXQt Settings -> Session Settings; "Autostart", untick XScreensaver.

    Cheers.

  6. #6
    Join Date
    Mar 2021
    Beans
    19

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Quote Originally Posted by guiverc View Post
    Screensaver (xscreensaver) and power management are already disabled--I confirmed in gui.

    Quote Originally Posted by ml9104 View Post
    Good.
    Next try is: Preferences -> LXQt Settings -> Session Settings; "Autostart", untick XScreensaver.

    Cheers.
    Yes, this was already unchecked. See screenshots below of various settings. As shown, I've alternately tried disabling and enabling idleness watcher with the settings shown.




    I also masked sleep, suspend, and hibernate systemd targets, and rebooted, as suggested various places:

    $ sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

    And confirmed the change:

    $ systemctl status sleep.target suspend.target hibernate.target hybrid-sleep.target

    ● sleep.target
    Loaded: masked (Reason: Unit sleep.target is masked.)
    Active: inactive (dead)


    ● suspend.target
    Loaded: masked (Reason: Unit suspend.target is masked.)
    Active: inactive (dead)


    ● hibernate.target
    Loaded: masked (Reason: Unit hibernate.target is masked.)
    Active: inactive (dead)


    ● hybrid-sleep.target
    Loaded: masked (Reason: Unit hybrid-sleep.target is masked.)
    Active: inactive (dead)


    None of this has helped. The system still times out and sleeps after 5 minutes or so.
    Last edited by Regexaurus; September 7th, 2021 at 11:36 PM.

  7. #7
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    1,162
    Distro
    Lubuntu Development Release

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    I'm still not sure the use of your customXsession script will help in anyway way, as you're not using a default/custom X session, but one created by Lubuntu I believe (ie. I suspect the creation of the ~/.xinitrc will do nothing); you also didn't mention specifying the shell to be used as per instructions, but I'm not sure that makes a difference as dash will be default.

    I wonder if you've installed various packages that may have pulled in other systems that have maybe taken over and replaced the LXQt ones (I left Power Management enabled so the settings I'd created that disabled it were read; the flipping of idleness watcher should do nothing if it's disabled as you've indicated)

    I've tried a number of boxes (focal or 20.04 & impish 21.10) using only the GUI tools to disable power/screensaver & each time the effect is I don't see a blank screen or screensaver kick in (in 12 mins it was watched for anyway).

    Given you appear to have made manual edits to config files, I'd check each of those files for errors (some programs/utilities can treat an error as the end-of-file-marker & not read further, eg. sudoers file, meaning later valid lines are ignored & defaults are used)

  8. #8
    Join Date
    Mar 2021
    Beans
    19

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Quote Originally Posted by guiverc View Post
    I'm still not sure the use of your customXsession script will help in anyway way, as you're not using a default/custom X session, but one created by Lubuntu I believe (ie. I suspect the creation of the ~/.xinitrc will do nothing); you also didn't mention specifying the shell to be used as per instructions, but I'm not sure that makes a difference as dash will be default.
    Well, it was something of a stab in the dark, which isn't great. The .xinitrc I created literally contained only the two lines I previously indicated. It contained no shebang line. So it was probably syntactically incorrect in addition to not being used by Lubuntu/LXQt. I've moved .xinitrc aside (renamed) to ensure it is inactive/unused, and rebooted for good measure. Not that it makes a difference, but bash is the default shell. It's possible I changed this, but I don't recall doing so, and I don't remember being prompted to select a default shell during install.



    Quote Originally Posted by guiverc View Post
    I wonder if you've installed various packages that may have pulled in other systems that have maybe taken over and replaced the LXQt ones (I left Power Management enabled so the settings I'd created that disabled it were read; the flipping of idleness watcher should do nothing if it's disabled as you've indicated)
    I've installed very little beyond default packages. The Rise Vision media player is installed since that is the purpose of the system.

    Quote Originally Posted by guiverc View Post
    Given you appear to have made manual edits to config files, I'd check each of those files for errors (some programs/utilities can treat an error as the end-of-file-marker & not read further, eg. sudoers file, meaning later valid lines are ignored & defaults are used)
    I doubt this is the problem. I moved .xinitrc aside as stated above. I did the same for .xscreensaver, then used a gui utility to configure (disable) the screensaver/xscreensaver. This automatically created another .xscreensaver.

    I also enabled power management and rebooted. Again, none of this made a difference. The system still times out / sleeps after about 5 minutes.
    Attached Images Attached Images

  9. #9
    Join Date
    Mar 2021
    Beans
    19

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    For kicks, I tried a one-time boot with acpi=off. That didn't work so well.



    I also tried a one-time boot with apm=off. As expected, this made no difference. The system still times out and sleeps/suspends the display. As stated in the original post, I can still ssh to the system when this happens, but doing so doesn't wake the screen. Normally, there are no input devices connected to the system. If I connect a physical USB keyboard and tap a key, it wakes the display.
    Attached Images Attached Images

  10. #10
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    875
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Disable display power management for Lubuntu 20.04 LTS / LXQt

    Looking at your screenshots in post #6 triggered my memory. I had this problem myself at one point (unwanted screen blanking, although the xscreensaver was turned off)
    Try unticking the "Lock screen before suspending/hibernating".
    It's totally unintuitive, but IIRC it works.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •