Results 1 to 3 of 3

Thread: v20.04 has blocked 2nd Monitor, Need proper driver for ASUS Nvidia GT610

  1. #1
    Join Date
    Mar 2010
    Location
    undisclosed
    Beans
    Hidden!
    Distro
    Ubuntu Studio

    v20.04 has blocked 2nd Monitor, Need proper driver for ASUS Nvidia GT610

    GPU: ASUS Nvidia GeForce GT610 w/2GB DDR3 Ram

    Mobo:
    MSI 990FXA-GD65 v2R

    CPU:
    AMD FX-8320 Vishera 8 core

    Recently upgraded from UbuntuStudio 18.04 to 20.04. After restart and next update, 2nd Monitor is ignored.
    Previously (in v18.04) it was using (in Software Updates/Additional Drivers) "Nvidia Metapackage from nvidia-driver-390 proprietary, tested".
    Now it is checked "continue using a manually installed driver", Nvidia GF119. Assuming it got it from either the ISO or online when installing v20.04. All other options are greyed out and unselectable!!!

    When opening Settings / DISPLAY - Wrong Resolution and can't select higher correct one. Also via Advanced Tab, "Configure new displays when connected", and "automatically enable profiles when display is connected" is checked.

    Proper drivers here? https://launchpad.net/ubuntu/+source...buntu0.20.04.1

    And Synaptic shows already installed ... How to ACTIVATE it ??? How can I update the driver for my GPU when the OS (snap?) has blocked me out???

    HELP ... Thanks!
    Last edited by Rick St. George; July 26th, 2021 at 05:03 PM. Reason: added URL

  2. #2
    Join Date
    Mar 2010
    Location
    undisclosed
    Beans
    Hidden!
    Distro
    Ubuntu Studio

    Re: v20.04 has blocked 2nd Monitor, Need proper driver for ASUS Nvidia GT610

    This is what I find when running;

    Code:
    ~$ ubuntu-drivers list
    WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
    nvidia-driver-390
    nvidia-340
    How can I fix this???

  3. #3
    Join Date
    Mar 2010
    Location
    undisclosed
    Beans
    Hidden!
    Distro
    Ubuntu Studio

    Re: v20.04 has blocked 2nd Monitor, Need proper driver for ASUS Nvidia GT610

    Wow.. Sometimes I amaze myself ... don't know exactly what I did, but a number of things.

    1. No Driver for latest kernel. Had to roll back to previous kernel 5.8.0.63 lowlatency.
    2. First had to make Grub show upon boot (modify Grub)
    3. installed all related to nvidia 390 following binary pkgs here https://launchpad.net/ubuntu/+source...buntu0.20.04.1
    4. Shut down, restart
    5. In repositories Software Updates / Additional Drivers selected "Nvidia driver metapackage 390 proprietary, tested"
    6. Shut down, restart - selecting via Grub / Advanced kernel 5.8.0.63 lowlatency
    7. Went into DISPLAY made settings for Resolution good in both monitors, and placed them accordingly.
    8. Shut down, restart.

    However, both displays ONLY work with the kernel option of 5.8.0.63 lowlatency .. NOTHING else.

    Is there anything we can do to prevent having to "roll back" to previous kernel EVERY day upon Boot-up?
    Last edited by Rick St. George; August 11th, 2021 at 03:11 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •