Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: No Man's Sky & Xubuntu 20.04: Not using iGPU?

  1. #1
    Join Date
    Jul 2015
    Location
    Essex, UK
    Beans
    689
    Distro
    Xubuntu

    No Man's Sky & Xubuntu 20.04: Not using iGPU?

    I have been trying to get this game working in 20.04 and 21.04, eventually re-installing 20.04. I reported this to ValveSoftware/Proton and received this reply:

    snip>

    Hello, looking at your system information, your system is not configured to use your GPU at all. Instead, llvmpipe and lavapipe are being used for software rendering on the CPU, which is not ideal at all. It looks like all the needed drivers are installed, but something is broken or misconfigured system-wide.

    From your system information:

    "vulkan: No DRI3 support detected - required for presentation",
    "Note: you can probably enable DRI3 in your Xorg config"
    [...]
    "libGL: screen 0 does not appear to be DRI2 capable",

    These hint that something major has been disabled. Blind guess, maybe the system was booted with modeset=0 as a kernel option?

    snip>

    I am unable to deal with that without assistance can I ask for help please?

    This is the system information as received from the Steam program and what I posted toValveSoftware/Proton:

    https://paste.ubuntu.com/p/tw75N22CYf/

    Code:
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "SwapBuffersWait" "0"
       Option      "DRI" "3"
    EndSection
    If I added this to the /usr/share/doc/xserver-xorg-video-intel/ file would it enable DRI3?

    The existing /usr/share/doc/xserver-xorg-video-intel/xorg.conf is:

    Code:
    Section "Device"
            Identifier "Intel"
            Driver "intel"
    #       Option "AccelMethod" "uxa"
    EndSection
    Last edited by makem2; July 26th, 2021 at 08:33 PM.

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,414
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    From a quick search I did find this:

    With Rocket Lake, the Linux support is all in order once again. But there is one sort of exception: the Gen12 Xe Graphics might not be working out-of-the-box depending upon your kernel. When I first booted up the Rocket Lake test system with Linux 5.12 + Mesa Git previously already installed, I was startled to find accelerated graphics not working... LLVMpipe was at play. This was a big surprise given Intel's track record and Gen12 Linux graphics support being out for a while now. Checking dmesg though quickly revealed that the PCI ID was still hidden behind the early support flag.

    Re-booting the system while having "i915.force_probe=4c8a" avoided the issue and accelerated graphics were quickly working. All was well on both the i5-11600K and i9-11900K processors when booting the stable Linux kernel with the force_probe option. While the patch to remove Rocket Lake from requiring the force probe has been on the mailing list for several months, as of writing it hasn't landed in the stable upstream Linux kernel. At the moment that is queued into DRM-Next ahead of Linux 5.13... We'll see if one of the "fixes" pull request soon removes this restriction. Some distribution kernels including the likes of Ubuntu are already carrying the patch for providing the Rocket Lake support out-of-the-box.

    So long story short, the Xe Graphics are ready to go for Linux users on sufficiently new kernels/Mesa, but you may end up needing to boot with the "i915.force_probe=4c8a" option in order to enable it for the time being.
    I don't know if that points you in the right direction. The Intel systems I've used haven't needed any fiddling, so I don't have any experience.

  3. #3
    Join Date
    Jul 2015
    Location
    Essex, UK
    Beans
    689
    Distro
    Xubuntu

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by CatKiller View Post
    From a quick search I did find this:



    I don't know if that points you in the right direction. The Intel systems I've used haven't needed any fiddling, so I don't have any experience.
    And I don't have any idea about "i915.force_probe=4c8a" so I have no idea where it points I'm afraid.

    I have had another reply from ValveSoftware/Proton which says that NMS will never run on the hardware I have and may not run on Windows even. That the game needs a dedicated GPU.

    However, it has run on Ubuntu 20.04, slow indeed but without any graphics problem in appearance. On Windows 10 it also runs, much quicker than on 20.04 but still a little slow.

    I am sure they are right and to get the games running at its best it does need a dedicated GPU. However, I am trying to get it to run once again on 20.04 with a view to having it working with a new GPU in time. I should have left well alone and not tried 21.04.

    Edit: This web page details how to use "i915.force_probe=4c8a"

    https://www.reddit.com/r/linuxhardwa..._using_latest/
    Last edited by makem2; July 26th, 2021 at 10:28 PM.

  4. #4
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,414
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by makem2 View Post
    However, it has run on Ubuntu 20.04, slow indeed but without any graphics problem in appearance.
    And from your version string (5.11.0-051100-generic) it looks like you've got your kernel from... somewhere... whereas when you had it working you were just using a standard Ubuntu kernel. Which makes sense, since Phoronix implies that Ubuntu apply the patches that enable it to work out of the box. The kernel version on my 20.04 (since I'm running hwe-edge) is 5.11.0-25(-lowlatency, but that part doesn't matter).

  5. #5
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    catkiller:

    That was when he installed a Newer Kernel from Mainline and updated his Mesa from the Kisak PPA...He had thata both installed, following leads that those worked for NMS and Intel UHD 730... But he was missing the piece you found (good job!) on the kernel boot line... he knows how to do all that now from the last two of his threads... Except how to test with with temporarily with adding that as a boot param from editing his Grub boot menu to test it...

    I'm just on a break at the moment... CatKiller, could you please talk him through that, for him to see? Either that, or I could in about 4 hours...
    Last edited by MAFoElffen; July 26th, 2021 at 11:27 PM.

    Concurrent coexistance of Windows, Linux and UNIX...
    Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    UbuntuForums system-info Script

  6. #6
    Join Date
    Jul 2015
    Location
    Essex, UK
    Beans
    689
    Distro
    Xubuntu

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    My current kernel is:

    Code:
    makem@makems-TUF:~$ uname -r
    5.11.0-051100-generic
    makem@makems-TUF:~$
    My grub file /etc/default/grub is:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.force_probe=4c8a"
    GRUB_CMDLINE_LINUX=""
    Further info:

    Code:
    makem@makems-TUF:~$ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Device 4c8a (rev 04)
    makem@makems-TUF:~$ find /dev -group video
    /dev/fb0
    /dev/dri/card0
    makem@makems-TUF:~$ glxinfo | grep -i vendor
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
        Vendor: Intel (0x8086)
    OpenGL vendor string: Intel
    makem@makems-TUF:~$ cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-5.11.0-051100-generic root=UUID=a018cecd-ae3a-4e56-8e59-a457c8dd43ab ro quiet splash i915.force_probe=4c8a vt.handoff=7
    makem@makems-TUF:~$ find /etc/modprobe.d/
    /etc/modprobe.d/
    /etc/modprobe.d/dkms.conf
    /etc/modprobe.d/blacklist-oss.conf
    /etc/modprobe.d/intel-microcode-blacklist.conf
    /etc/modprobe.d/blacklist-rare-network.conf
    /etc/modprobe.d/blacklist.conf
    /etc/modprobe.d/amd64-microcode-blacklist.conf
    /etc/modprobe.d/blacklist-ath_pci.conf
    /etc/modprobe.d/alsa-base.conf
    /etc/modprobe.d/blacklist-firewire.conf
    /etc/modprobe.d/iwlwifi.conf
    /etc/modprobe.d/blacklist-modem.conf
    /etc/modprobe.d/blacklist-framebuffer.conf
    makem@makems-TUF:~$ cat /etc/modprobe.d/*kms*
    # modprobe information used for DKMS modules
    #
    # This is a stub file, should be edited when needed,
    # used by default by DKMS.
    makem@makems-TUF:~$ ls /etc/X11/xorg.conf
    ls: cannot access '/etc/X11/xorg.conf': No such file or directory
    makem@makems-TUF:~$ glxinfo | grep -i "vendor\|rendering"
    direct rendering: Yes
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
        Vendor: Intel (0x8086)
    OpenGL vendor string: Intel
    makem@makems-TUF:~$ grep LoadModule /var/log/Xorg.0.log
    [     4.098] (II) LoadModule: "glx"
    [     4.105] (II) LoadModule: "modesetting"
    [     4.106] (II) LoadModule: "fbdev"
    [     4.106] (II) LoadModule: "vesa"
    [     4.131] (II) LoadModule: "fbdevhw"
    [     4.131] (II) LoadModule: "glamoregl"
    [     4.276] (II) LoadModule: "fb"
    [     4.471] (II) LoadModule: "libinput"
    makem@makems-TUF:~$ ls /usr/share/doc/xserver-xorg-video-intel/
    changelog.Debian.gz  copyright  NEWS.gz  README  README.Debian  xorg.conf
    makem@makems-TUF:~$
    xorg.conf:

    Code:
    Section "Device"
        Identifier "Intel"
        Driver "intel"
    #    Option "AccelMethod" "uxa"
    EndSection
    Code:
    makem@makems-TUF:~$ lspci -k | grep -EA3 'VGA|3D|Display'
    00:02.0 VGA compatible controller: Intel Corporation Device 4c8a (rev 04)
        DeviceName: Onboard - Video
        Subsystem: ASUSTeK Computer Inc. Device 8694
        Kernel driver in use: i915
    makem@makems-TUF:~$
    vulkaninfo | less result:
    Code:
    ===========
    VULKAN INFO
    ===========
    
    Vulkan Instance Version: 1.2.70
    
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_lvp.so: wrong ELF class: ELFCLASS32
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_lvp.so: wrong ELF class: ELFCLASS32
    ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
    
    
    
    
    
    
    
    
    Instance Extensions:
    ====================
    Instance Extensions     count = 18
    vt.handoff=7 - what is that for in grub?
    Last edited by makem2; July 27th, 2021 at 12:10 AM.

  7. #7
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,414
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by makem2 View Post
    My grub file /etc/default/grub is:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.force_probe=4c8a"
    GRUB_CMDLINE_LINUX=""
    Cool. Once you've saved that change to the file, you'll need to run
    Code:
    sudo update-grub
    to apply the change in configuration to the files that your machine uses to boot. Then reboot to test.

    Should it all go pear-shaped, you can edit the boot parameters from the Grub menu. Just in case you're unable to boot otherwise.

  8. #8
    Join Date
    Jul 2015
    Location
    Essex, UK
    Beans
    689
    Distro
    Xubuntu

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by CatKiller View Post
    And from your version string (5.11.0-051100-generic) it looks like you've got your kernel from... somewhere... whereas when you had it working you were just using a standard Ubuntu kernel. Which makes sense, since Phoronix implies that Ubuntu apply the patches that enable it to work out of the box. The kernel version on my 20.04 (since I'm running hwe-edge) is 5.11.0-25(-lowlatency, but that part doesn't matter).
    Are you suggesting that maybe I should go back to kernel 5.8.0.63.71 which is still installed if 5.11 is not working and wait for an update coming through as it may have done previously?

  9. #9
    Join Date
    Jul 2015
    Location
    Essex, UK
    Beans
    689
    Distro
    Xubuntu

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by CatKiller View Post
    Cool. Once you've saved that change to the file, you'll need to run
    Code:
    sudo update-grub
    to apply the change in configuration to the files that your machine uses to boot. Then reboot to test.

    Should it all go pear-shaped, you can edit the boot parameters from the Grub menu. Just in case you're unable to boot otherwise.
    Yes I was aware that I needed to run update-grub and did so to achieve the result posted.

    I did reboot and it did not go pear shaped

    NMS gave me a black screen though without errors - been there before with 21.04.

  10. #10
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,414
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: No Man's Sky & Xubuntu 20.04: Not using iGPU?

    Quote Originally Posted by makem2 View Post
    Are you suggesting that maybe I should go back to kernel 5.8.0.63.71 which is still installed if 5.11 is not working and wait for an update coming through as it may have done previously?
    The 5.8 branch was working in ways that the others you've installed haven't been, so that seems desirable. Then maybe trying the hwe and hwe-edge branches, since they'll have all of Ubuntu's patches installed.

    Quote Originally Posted by makem2 View Post
    Yes I was aware that I needed to run update-grub and did so to achieve the result posted.
    Yay!
    I did reboot and it did not go pear shaped
    Yay!
    NMS gave me a black screen though without errors - been there before with 21.04.
    Boo...

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •