Results 1 to 8 of 8

Thread: Graphics won't start on boot with ndivia-driver-460 and -465

  1. #1
    Join Date
    Jun 2021
    Beans
    5

    Graphics won't start on boot with ndivia-driver-460 and -465

    Hello,
    I need some help diagnosing a problem with my graphics driver.
    I had nvidia-driver-460 installed and was happy with it, but a few weeks ago there was an update, and since then the boot sequence seems to complete but would stop before actually starting the graphical interface.
    Switching to TTY2 also doesn't work, and the same problem happens with nvidia-driver-465.
    Luckily nividia-driver-390 is still available, and with that one everything works (with the nouveau driver as well, except for some games).

    I've tried a clean install, but that didn't resolve the problem.
    My motherboard is an ASUS TUF X470-PLUS GAMING
    My graphics card is a NVIDIA Corporation GP104 [GeForce GTX 1070]
    I've attached the boot.log and dmesg from a failed boot, but I'm not knowledgable enough to notice anything wrong.
    I would appreciate any help in further diagnosing/solving this problem.
    Thank you in advance.
    Attached Files Attached Files

  2. #2
    Join Date
    Sep 2009
    Location
    Oregon
    Beans
    159
    Distro
    Kubuntu Development Release

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    I'm just a stupid user, so I can't help with your logs, but did you purge every mention of Nvidia on your system via the terminal?
    I had a similar situation happen to me. I was getting screen-tearing, so I tried to roll back my driver, and I could only boot into safe graphics after that.
    I had to uninstall the proprietary driver, then reboot to safe graphics again.

    After logging in, I followed the advice here to purge Nvidia:
    https://askubuntu.com/questions/2062...A%20See%20More.

    IIRC, I also opened up Muon (in your case Synaptic Package Manager), and did a search for nvidia, and purged every installed entry, then followed the instructions above again.

    Then I rebooted, and ran the driver tool, and let it install 460, and rebooted again. That did it for me. Hope it helps you.
    Oh, Linux... if only I had known.

  3. #3
    Join Date
    Jun 2021
    Beans
    5

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    Thank you for your speedy answer.
    Unfortunately, I've already tried this and it didn't work for me.

  4. #4
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,599
    Distro
    Xubuntu

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    Where are you getting the drivers from? The repos or nVidia's site? Is this a laptop or desktop?

  5. #5
    Join Date
    Jun 2021
    Beans
    5

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    From the repo's (installed with the drivers GUI). This is on a desktop.

  6. #6
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    have you tried uninstalling the driver and then reinstalling it using same method?

    it happened to my kid once. kernel was somehow patched, but the drivers didn't patch. so removing them (purge), booting into nouveau and then installing them again fixed the issue.

    second answer here is less messy: https://askubuntu.com/questions/2062...ver-completely

    or you can try via GUI. but it is important you purge, clean and reinstall.
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

  7. #7
    Join Date
    Jun 2021
    Beans
    5

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    Thank you.
    Yes, I've tried that, but unfortunately this still doesn't resolve the issue.
    Even after a clean install it still won't work

  8. #8
    Join Date
    Jun 2021
    Beans
    5

    Re: Graphics won't start on boot with ndivia-driver-460 and -465

    It seems the new nvidia-driver-470 has resolved the issue

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •