Results 1 to 2 of 2

Thread: MSI GL62 Windows 10/Xubuntu dual booting problem

  1. #1
    Join Date
    Jul 2021
    Beans
    1

    MSI GL62 Windows 10/Xubuntu dual booting problem

    Dear participants of the Ubuntu forum community,

    I have a laptop (MSI GL62 7QF) with pre-installed Windows 10. Windows 10 peacefully coexisted with Xubuntu 18.04 LTS Bionic Beaver. I have never experienced any issues with GRUB until the last Windows update, which has changed the BIOS, UEFI configurations and disabled GRUB.

    I have been trying to use boot-repair to fix the issue twice, but it didn’t help. Windows boot manager was working after my first try. According to pieces of advice given in different forum threads, I tried to change the default boot entry of the Windows bootloader. This change was fatal, and now even Windows boot manager doesn’t work. As you can understand, I did not succeed with the second attempt of fixing the problem with the help of boot-repair (https://sourceforge.net/p/boot-repair-cd/home/Home/ ).

    Here you can find the report generated by the boot-repair:
    http://paste.ubuntu.com/p/p743hnTZMw/

    I am feeling desperate. Please, help me to fix these bootloader problems and recover access to both operational systems! Deadlines are pressing on me, and I didn’t expect to get such an unpleasant surprise from Windows Update.

    Sincerely yours,
    Eduard


  2. #2
    Join Date
    Jun 2014
    Beans
    6,269

    Re: MSI GL62 Windows 10/Xubuntu dual booting problem

    You have two entries for Windows Boot Manager and the 0000 entry is point to Ubuntu (line 36) and the correct entry is 0004 which points to the correct windows EFI boot file so change that in the BIOS firmware. You can also change if with sudo efibootmgr from Ubuntu. This likely happened when you tried to change the boot order.

    Code:
     sudo efibootmgr -o 0004
    After doing this, if windows boots successfully, go into windows and make sure you have hibernation disabled as some windows updates will turn it back on and Grub will not boot a hibernated windows system. Then select Ubuntu from the BIOS boot options and run: sudo update-grub and watch to see if you get a windows entry. If this is successful, you can then reset the Ubuntu entry (0005) to first boot priority in the BIOS.

    In the future, any time you do an update on windows, verify that hibernation is off.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •