Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Tab opening on new window is slowly driving me crazy...

  1. #1
    Join Date
    Aug 2005
    Beans
    431

    Tab opening on new window is slowly driving me crazy...

    This must happen to me at least 13 times a day.

    I click on a tab in chrome and the tab opens in a new window. Then I have to click on the tab again and put it back in it's original window.

    And on and on and on...

    Pls tell me there is some sort of chrome hack to stop this happening in the future....

    thanks,
    I wish my computer would do what I want it to do - not what I tell it to do.

  2. #2
    Join Date
    Aug 2013
    Beans
    4,723

    Re: Tab opening on new window is slowly driving me crazy...

    Tabs don't open in new window unless you choose to. You must have set some kind of preferences or maybe an extension is acting up.

  3. #3
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    2,323
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Tab opening on new window is slowly driving me crazy...

    Happens to me in Firefox a lot also. I have never been able to figure out why. I am running Xubuntu 20.04. I think it may be a mouse thing but what I don't know.

  4. #4
    Join Date
    Dec 2014
    Beans
    1,847

    Re: Tab opening on new window is slowly driving me crazy...

    If this happens with a touchpad, I'd try unsetting 'Tapping Drag Enabled' using xinput ('xinput set-prop devicename "libinput Tapping Drag Enable" 0'). If it's a mouse than you might try setting the distance the mouse can be moved with a button pressed before it gets recognized as a 'drag' higher (in XUbuntu that's available in the mouse settings applet, don't know about other flavours ...).

    Holger

  5. #5
    Join Date
    Aug 2005
    Beans
    431

    Re: Tab opening on new window is slowly driving me crazy...

    I get this error message when i try your solution Holger.

    Wasn't there supposed to be a config file in /etc that I could use to adjust the touchpad? Or is that gone now?

    dara@laptop-20-04:~$ xinput set-prop 'SynPS/2 Synaptics TouchPad' "libinput Tapping Drag Enable" 0
    property 'libinput Tapping Drag Enable' doesn't exist, you need to specify its type and format
    dara@laptop-20-
    I wish my computer would do what I want it to do - not what I tell it to do.

  6. #6
    Join Date
    Dec 2014
    Beans
    1,847

    Re: Tab opening on new window is slowly driving me crazy...

    Check what properties do exist for your touchpad with "xinput list-props 'SynPS/2 Synaptics TouchPad"; the names are mostly quite self-explanatory. And yes, you could set up a configuration file for the touchpad in /etc/X11/xorg.conf.d/, (assuming that you're using X and not Wayland ...). But X on Ubuntu is mostly self-configuring - so there are no config files by default - and a bad enough mistake in a configuration file might break X to the point where you have to go to a virtual terminal to fix things, so I usually avoid going that route.

    Holger

  7. #7
    Join Date
    Aug 2005
    Beans
    431

    Re: Tab opening on new window is slowly driving me crazy...

    @Holger_Gehrke

    dara@laptop-20-04:~$ xinput list-props "SynPS/2 Synaptics TouchPad"
    WARNING: running xinput against an Xwayland server. See the xinput man page for details.
    unable to find device SynPS/2 Synaptics TouchPad
    dara@laptop-20-04:~$ cat /proc/bus/input/devices | grep -i 'touchpad'
    N: Name="SynPS/2 Synaptics TouchPad"
    man XWaypoint isn't very useful. Still having the same issue.

    Tried Settings->Touchpad but that doesn't seem to help...
    I wish my computer would do what I want it to do - not what I tell it to do.

  8. #8
    Join Date
    Dec 2014
    Beans
    1,847

    Re: Tab opening on new window is slowly driving me crazy...

    If you're using Wayland, configuring the touchpad through xinput is not going to be very useful because you're only configuring the X11 emulation layer of Wayland and programs that talk to Wayland directly will not be influenced by your configuration. With Wayland it's mostly graphical configuration or nothing. If the graphical tools don't offer a way to do something, then you're out of luck on Wayland.

    You might try to find out the right name to use for your touchpad in xinput with 'xinput list --name-only'. The right name for your touchpad should be obvious on that list. There's also 'libinput list-devices' which should work with Wayland correctly. The 'libinput' executable will allow you to see settings for all devices controlled through libinput but sadly has no way to change those settings.

    Holger

  9. #9
    Join Date
    Aug 2005
    Beans
    431

    Re: Tab opening on new window is slowly driving me crazy...

    thanks @Holger_Gehrke

    Code:
    Device:           SynPS/2 Synaptics TouchPad
    Kernel:           /dev/input/event4
    Group:            7
    Seat:             seat0, default
    Size:             119x62mm
    Capabilities:     pointer gesture
    Tap-to-click:     disabled
    Tap-and-drag:     enabled
    Tap drag lock:    disabled
    Left-handed:      disabled
    Nat.scrolling:    disabled
    Middle emulation: disabled
    Calibration:      n/a
    Scroll methods:   *two-finger edge 
    Click methods:    *button-areas clickfinger 
    Disable-w-typing: enabled
    Accel profiles:   flat *adaptive
    Rotation:         n/a
    so you're saying i can see the value is enabled in Wayland. But i can't disable it?
    I wish my computer would do what I want it to do - not what I tell it to do.

  10. #10
    Join Date
    Dec 2014
    Beans
    1,847

    Re: Tab opening on new window is slowly driving me crazy...

    Quote Originally Posted by dbee View Post
    So you're saying i can see the value is enabled in Wayland. But i can't disable it?
    That's my understanding of the situation, yes. It might be possible to make some settings through 'gsettings set org.gnome.desktop.peripherals.touchpad settingname settingvalue', but since I don't use Gnome (or Wayland for that matter; I'm using XUbuntu and XFCE isn't compatible with Wayland ... yet ...) I can't test this.

    I find it strange that you have tap-to-click deactivated and tap-and-drag active. From my reading of the libinput documentation tap-and-drag only works if tap-to-click is active.

    Holger

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •