Results 1 to 6 of 6

Thread: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

  1. #1
    Join Date
    Nov 2015
    Beans
    205

    18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    Hi there,

    I'm having a strange issue where going to an active window, or occasionally doing something (choosing an option or typing in software) will cause my monitor to turn off for a second or so, and turn back on again.

    The monitor is fine on my Win10 work PC. But does the above when connected to mu linux box (in both lubuntu 18.04 and 20.04). Connection is via HDMI.

    It;s a very hard issue to search - any ideas?

  2. #2
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    1,127
    Distro
    Lubuntu Development Release

    Re: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    I saw this yesterday (my local time) as you posted it, and hope you'd get response from others.

    Firstly the warning - Lubuntu 18.04 LTS is no longer supported by the Lubuntu team as it's EOL, please refer https://lubuntu.me/bionic-eol/ Yes some packages (those common with main Ubuntu 18.04 LTS) are still supported with security fixes, but that's not all packages, and you can use `ubuntu-support-status` on your own box to see which packages those are, and how it impacts your security status.

    Yes I've seen the issue, and it included Lubuntu 18.04 LTS, 20.04 & more too, but it was not on a nvidia box (AMD card).

    You mention screen cable being HDMI - are you sure the cable is secured correctly? Is the system dual booting and the windows works using the same box & same cable?

    If your windows is using a different box, I'd likely boot a live system (I'd opt first with something very different to Lubuntu you're using, ie. a non-Ubuntu is what I'd opt for firstly and something with a different kernel stack; whatever you have handy if you have something; eg. I may use Knoppix, Fedora or Debian that I believe exist on thumb-drives already for me). You're testing the same hardware/cable to see if the issue occurs using different software... If it does it's most likely a cable that needs testing, connector that needs a clean etc..

    If you don't have issues with that different system, I'd then again test with a live system, but this time a like system to what you have installed; ie. Lubuntu 20.04 media if that's what you have installed.. (if you're using the GA stack on your install; I'd test using media that also uses the GA stack; eg. 20.04.1 media; if using HWE then I'd use 20.04.2 (or 20.04.3) media and see if it occurs there. If it occurs were too; it's possibly a software stack issue (why you test with as close a stack as you can here), if it doesn't occur here it's likely a config issue on your installed system... The nvidia being used makes it harder to test with Lubuntu; I may opt to test using another flavor here though I forget what drivers are included on focal media (I just know Lubuntu doesn't include any!). Live with persistence may help here, but it may not (I don't use it generally with nvidia drivers so don't know sorry).

    Myself - I'd blame the hardware until I'd proven it wasn't hardware (hardware includes cable & connectors..). I'd use the live media to test other software to sort of prove it's hardware; or if the issue doesn't occur with live media then it's likely a config or package issue on your installed system.

    On my own box; it occurs on live and my installed systems so I concluded it was likely a cable issue; but rather than move boxes on top of it (the box is in a stack of boxes) I'll live with it until I'm forced to replace boxes in that stack and it's easy to reach (I'm lazy). My own box has windows xp installed on it (a somewhat buggy game (red alert) I like is less hassle (when it crashes) there than under GNU/Linux); and it occurs on xp too; though doesn't appear to blank as often in xp; but maybe I'm not gaming as much as doing real stuff on the GNU/Linux so I just don't notice it much).

    If after that testing you conclude it's a software/config issue on your install... Which stack were you using, you mention 18.04 & 20.04; if using the HWE stack on bionic and GA stack on focal they'll both be using the same stack, thus I'd install the HWE stack on the focal and see if it occurs there (or if you don't want to install it; test that via live media). Focal or 20.04 uses the 5.4 kernel on GA, and currently the 5.8 on HWE (though it'll soon bump to 5.11)..

    Anyway, that's a few thoughts... (Note: I'm largely ignoring the nvidia-340, as whilst I've used it... I have no useful detail with it)

  3. #3
    Join Date
    Nov 2015
    Beans
    205

    Re: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    Thanks for the suggested approach. What I'll do first is connect up the windows box using the same (HDMI) cable, and use that setup at work today.

  4. #4
    Join Date
    Nov 2015
    Beans
    205

    Re: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    P.s. I love that you keep an XP install around for C&C Red Alert - that is a legendary thing to do!

  5. #5
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,414
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    Off topic, but
    Quote Originally Posted by guiverc View Post
    My own box has windows xp installed on it (a somewhat buggy game (red alert) I like is less hassle (when it crashes) there than under GNU/Linux)
    are you familiar with OpenRA? It might be nicer for you than running the original on XP or in Wine.

  6. #6
    Join Date
    Nov 2015
    Beans
    205

    Re: 18.04 / 20.04 HDMI monitor briefly turning off and on NVIDIA-340

    Quote Originally Posted by steve234 View Post
    Thanks for the suggested approach. What I'll do first is connect up the windows box using the same (HDMI) cable, and use that setup at work today.
    So I've done this and it worked flawlessly on Windows all day (same cable). I think I'll just have to live with it

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •