Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: wifi was working fine until i disabled the turn off wifi to save power option

  1. #1
    Join Date
    Jun 2021
    Location
    India
    Beans
    18
    Distro
    Ubuntu 20.04 Focal Fossa

    Unhappy wifi was working fine until i disabled the turn off wifi to save power option

    now its showing no wifi adapter found.
    Code:
    $ lshw -c network
    
     *-network                 
           description: Ethernet interface
           product: RTL810xE PCI Express Fast Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:08:00.0
           logical name: enp8s0
           version: 07
           serial: 14:58:d0:ca:fc:ff
           capacity: 100Mbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.8.0-59-generic firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:18 ioport:4000(size=256) memory:b5500000-b5500fff memory:b5400000-b5403fff
      *-network
           description: Ethernet interface
           physical id: 3
           bus info: usb@2:1
           logical name: usb0
           serial: 56:20:63:78:58:a1
           capabilities: ethernet physical
           configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.30 link=yes multicast=yes
    
    
    
    
    
    $ lsmod
    
    (...)
    realtek     24576  1
    
    
    
    
    $ sudo iwconfig
    
    lo        no wireless extensions.
    
    enp8s0    no wireless extensions.
    
    usb0      no wireless extensions.
    
    
    sudo iwlist scanning
    
    lo        Interface doesn't support scanning.
    
    enp8s0    Interface doesn't support scanning.
    
    usb0      Interface doesn't support scanning.
    Last edited by QIII; June 27th, 2021 at 05:27 PM. Reason: code tags added

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,632
    Distro
    Ubuntu Development Release

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    until i disabled the turn off wifi to save power option
    Where and importantly, why did you do this?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Jun 2021
    Location
    India
    Beans
    18
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    i was having problems connecting to wifi, it simply just wouldn't connect to after sleep.
    so i looked into the power settings and found this option "turn off wifi to save power" and disabled it, thought it would help but things got worse.
    now that option isn't even available in the power section of settings.
    Last edited by akashsinhaha; June 27th, 2021 at 08:49 AM.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,632
    Distro
    Ubuntu Development Release

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    Please show us:

    Code:
    lspci -nnk | grep 0280 -A3
    lsusb
    Please check for any options to enable/disable wireless in the BIOS/EFI.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #5
    Join Date
    Jun 2021
    Location
    India
    Beans
    18
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    for
    Code:
    lspci -nnk | grep 0280 -A3
    it gave me

    Code:
    0a:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
        Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]
        Kernel driver in use: rt2800pci
        Kernel modules: rt2800pci, wl
    
    and for lsusb it gave
    
    Bus 001 Device 003: ID 0bda:5776 Realtek Semiconductor Corp. 
    Bus 001 Device 002: ID 8087:8000 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 003: ID 2717:ff80 Xiaomi Inc. Mi/Redmi series (RNDIS)
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Last edited by QIII; June 27th, 2021 at 05:26 PM. Reason: code tags

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,632
    Distro
    Ubuntu Development Release

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    Please do:
    Code:
    sudo apt purge bcmwl-kernel-source
    sudo dmesg | grep rt28
    Then post the result.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #7
    Join Date
    Jun 2021
    Location
    India
    Beans
    18
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    after running
    Code:
    sudo apt purge bcmwl-kernel-source
    sudo dmesg | grep rt28
    this is the result

    Code:
    [   20.603864] rt2800pci 0000:0a:00.0 wlp10s0f0: renamed from wlan0
    Last edited by QIII; June 27th, 2021 at 05:26 PM. Reason: code tags added

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,632
    Distro
    Ubuntu Development Release

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    Please reboot and show us:

    Code:
    sudo dmesg | grep -e rt2 -e wlp
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #9
    Join Date
    Jun 2021
    Location
    India
    Beans
    18
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    after rebooting this is what it shows

    Code:
    [   19.889025] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3290, rev 0015 detected
    [   19.897072] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 3290 detected
    [   19.996765] rt2800pci 0000:0a:00.0 wlp10s0f0: renamed from wlan0
    Last edited by QIII; June 27th, 2021 at 05:25 PM. Reason: code tags added

  10. #10
    Join Date
    May 2014
    Location
    /home
    Beans
    9,532
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: wifi was working fine until i disabled the turn off wifi to save power option

    What about results for
    Code:
    ifconfig; iwconfig; sudo cat /var/lib/NetworkManager/NetworkManager.state

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •