I'm running 21.04 on an older desktop sitting in my garage where I use it as a file server for backups. The integrated wifi adapter is only 2Ghz and I want to upgrade it to dual band so I found an old Netgear USB adapter but I can't get the driver to work.
I've tried a couple of drivers on github that require a make process; one finishes with a couple errors but doesn't work and the other gives a whole bunch of mkdir errors. I probably should brush up on the Makefile stuff as I haven't had to use it in years.

Anyway what I seem to find is that Netgear doesn't support linux (how can that be?) and a lot of other people have struggled with this. Is there a driver that I can just drop in without going through the make process?

Regarding the internal AP, when I run iwconfig, both are shown but if I run sudo iwlist scan, I get an error for the A6210 (wlx9c3dcff99353 Failed to read scan data : Resource temporarily unavailable). This does beg the question of if/when I get the dual band unit to work, how do I turn off the internal AP?

Anyway, I'd like to fight my way through this but could use some guidance. If I can't get this to work I guess I'll just buy a pcie unit from Amazon and hope that it comes with a supported driver...

Thanks in advance.