Results 1 to 6 of 6

Thread: gnome 3 disable "touch" mode

  1. #1
    Join Date
    Jun 2021
    Beans
    5

    gnome 3 disable "touch" mode

    Hello,


    Hope to be in the right place with my post (sorry if not). I have a problem with an Epson beamer model (695wi). I imagine that's the same with all touch devices that support multi-touch with the Ubuntu 20.04 (gnome version). It goes into touch mode (no more cursor, applies different gesture recognition etc. ). This mode is very interesting except that it does not work as well as it should work (random click, gesture rarely understood by the system etc.)! Maybe it's an hardware problem (695wi). Anyway this problem occur with all 695wi beamers i tried (something like 10 or more..) and my users can't use their computers like this.


    Do you have any idea how to turn off this feature while still keeping the touch of my screen ? -> on my previous configuration (mint 18.3) the (touch) screen was considered as a mouse and ubuntu (mint) did not switch to its "touch" mode and everything worked correctly.


    - I tested with xinput, I can't remove this mode .. I can see several pointing devices but despite deactivation nothing happens until the pure and simple deactivation of the touch screen.
    - tested with the evdev conf and nothing to do. it's either everything or nothing ..


    Thank you for your help.

  2. #2
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: gnome 3 disable "touch" mode

    I must be confused.

    By your post content as a whole, I initially assumed that you where talking about a tablet, or a 2-In-One... Where it is going into Tablet mode. But When I look up "Epson 695wi", all I see is a projector. Am I wrong with that? What is Ubuntu running on?

    From what you are asking and trying, I interpret that as can the Tablet mode by disabled, while still keeping touch screen input, as with the modes of a touch screen laptop or notepad. Right? That is what I am looking into.

    In the meanwhile, you said you tried to use xinput... What was the results of
    Code:
    xinput --list
    Last edited by MAFoElffen; June 16th, 2021 at 12:57 AM.

    Concurrent coexistance of Windows, Linux and UNIX...
    Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    UbuntuForums system-info Script

  3. #3
    Join Date
    Jun 2021
    Beans
    5

    Re: gnome 3 disable "touch" mode

    Thank you very much for your answer. It is a projector with a touch unit (laser scanning sensor) used for teaching primary classes. A kind of "next gen blackboard".

    xinput --list :

    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Primax HP USB Keyboard Consumer Control id=11 [slave pointer (2)]
    ⎜ ↳ Logitech Wireless Mouse PID:003f id=13 [slave pointer (2)]
    ⎜ ↳ Logitech Wireless Keyboard PID:0045 id=14 [slave pointer (2)]
    ⎜ ↳ PixArt HP USB Optical Mouse id=15 [slave pointer (2)]
    ⎜ ↳ EPSON EPSON EPSON 695Wi/695WT Mouse id=16 [slave pointer (2)]
    ⎜ ↳ EPSON EPSON EPSON 695Wi/695WT Mouse id=17 [slave pointer (2)]
    ⎜ ↳ EPSON EPSON EPSON 695Wi/695WT Mouse id=18 [slave pointer (2)]
    ⎜ ↳ EPSON EPSON EPSON 695Wi/695WT id=19 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Primax HP USB Keyboard id=10 [slave keyboard (3)]
    ↳ Primax HP USB Keyboard System Control id=12 [slave keyboard (3)]
    ↳ HP WMI hotkeys id=20 [slave keyboard (3)]
    ↳ Primax HP USB Keyboard Consumer Control id=21 [slave keyboard (3)]
    ↳ Logitech Wireless Keyboard PID:0045 id=22 [slave keyboard (3)]

  4. #4
    Join Date
    Jun 2021
    Beans
    5

    Re: gnome 3 disable "touch" mode

    Quote Originally Posted by MAFoElffen View Post
    From what you are asking and trying, I interpret that as can the Tablet mode by disabled, while still keeping touch screen input, as with the modes of a touch screen laptop or notepad. Right? That is what I am looking into.
    The problem is that a lot of content is unusable with this "tablet mode" because the click, double click etc ... actions are too risky. Until now I used a mint 18 version and this beamer was recognized by the system as a mouse so no multi-touch but a more reliable behavior. the goal is to find out how i can keep the touchscreen function like a mouse and force ubuntu not to go into "tablet" mode.

  5. #5
    Join Date
    Jun 2021
    Beans
    5

    Re: gnome 3 disable "touch" mode

    any idea ??

  6. #6
    Join Date
    Jun 2021
    Beans
    5

    Re: gnome 3 disable "touch" mode

    I found a solution that worked for me. Thanks to :


    https://askubuntu.com/questions/9270...-using-wayland


    If I disable the hid_multitouch driver the beamer is not recognized as a touch screen by the system but as a mouse. This does not enable the touch mode.


    ==========


    create the file hid_multitouch.conf in /etc/modprobe.d


    Inside the file :


    # Use the following syntax
    # blacklist driver-name
    blacklist hid_multitouch

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •