Results 1 to 3 of 3

Thread: xubuntu install hangs

  1. #1
    Join Date
    Jul 2016
    Beans
    11

    xubuntu install hangs

    I am trying to install Xubuntu on a Toshiba Satellite laptop. I initially tried to install 18.04 from a USB flash drive, but the installer would hang no matter what parameters I set. I read a suggestion about trying an earlier version and then upgrading from that, so I then installed 16.04 from a USB drive.

    That seemed to work fine, and the computer worked well for several hours. I then attempted to upgrade but all attempts failed. The GUI became unstable. That is, it would work for a few minutes but then the mouse and keyboard would stop responding.

    Thinking that my software updates had caused this problem, I tried reinstalling 16.04 from scratch, but the problem persists. Now I can't get it to do anything for more than a few minutes before the mouse and keyboard quit.

    Did I do something to mess up the firmware? Is there a way to fix this without installing Windows?

  2. #2
    Join Date
    May 2010
    Beans
    1,892

    Re: xubuntu install hangs

    Why 18.04 ? Why not 20.04 which is newer and supported for longer ?
    Did you SHASUM / MD5SUM the ISO you downloaded to make sure it was complete and consistent ?

  3. #3
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    1,226
    Distro
    Lubuntu Development Release

    Re: xubuntu install hangs

    Are you aware that flavors of Ubuntu only come with three years of supported life (five years applies to Ubuntu Desktop, Ubuntu Server but not flavors),

    - https://fridge.ubuntu.com/2020/08/14...-lts-released/
    - UWN - https://wiki.ubuntu.com/UbuntuWeekly...pport_Statuses highlights the EOL notices for Lubuntu/Ubuntu-MATE/Kubuntu/Ubuntu-Budgie

    Xubuntu didn't announce EOL but refer https://xubuntu.org/release/18-04/ you'll see it's EOL was 29 April 2021.

    From your description, it reads to me like

    - hardware issues (did you run ram tests, visually scan motherboard looking for swollen caps, check PSU, drive health etc), or

    - lack of validation of the system (no clues were given that you verified your ISO, or write to installation media, checked logs for clues, did SysRq commands work to direct kernel to cleanly reboot/shutdown or was it frozen which implies hardware issues are more likely; SysRq commands work even on a locked GUI session where mouse/keyboard (excluding SysRq) don't work).

    You also didn't provide any specs, did you go for 18.04 because your box is i386? or 32-bit x86? and that's why you're opting for unsupported software over supported releases?

    FYI: All of 16.04 is out of standard support (not just flavors). See https://fridge.ubuntu.com/2021/03/13...april-30-2021/ but does have ESM support, see https://ubuntu.com/blog/ubuntu-16-04...aintenance-esm

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •