Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Error, bug or something else

  1. #1
    Join Date
    May 2021
    Beans
    8

    Error, bug or something else

    I'm a little gun shy here, as my first question on this forum was met with a face full of arrogant condescension. I'll give it another go, and hope someone else answers. First time this came up, I somehow managed to report it, but don't know if I could do it again. In response to the answer I got, I'm pretty sure I've got no hardware issues, even though this machine is old (probably ancient in computerspeak). It's other wise running as smooth as silk.
    Anyway, here goes. When I try to upgrade - this happens

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    evolution : Depends: evolution-common (= 3.36.5-0ubuntu1) but 3.36.4-0ubuntu1 is to be installed
    libevolution : Depends: evolution-common (= 3.36.5-0ubuntu1) but 3.36.4-0ubuntu1 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

  2. #2
    Join Date
    Feb 2015
    Beans
    Hidden!
    Distro
    Ubuntu Mate 18.04 Bionic Beaver

    Re: Error, bug or something else

    Quote Originally Posted by wilsojeffrey View Post
    ...You might want to run 'apt --fix-broken install' to correct these...
    Try running the command ...
    Code:
    sudo apt --fix-broken install
    ... as suggested by the terminal output you posted if you haven't already tried such.

    Post back any further terminal errors if they occur, preferably between [CODE][/CODE] tags. To do so use the "Go Advanced" option and use the "#" button to insert the code tags then copy/paste in your terminal output between them. Doing so makes it much easier for helpers to read and interpret terminal output in your posts.

    Regards, yeti.
    Last edited by yetimon_64; June 10th, 2021 at 09:10 AM. Reason: Changed "Advanced reply" to "Go Advanced"

  3. #3
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,925
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Error, bug or something else

    Let's see. What output does it give you when you run
    Code:
    sudo apt update
    sudo apt --fix-broken install
    That may give a more helpful error message.

    The apt update command is to ensure your package manager has the latest information about available packages.

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Error, bug or something else

    Welcome wilsojeffrey

    - Which version of Ubuntu are you running (20.04.x LTS or some other version)?
    - Can you think of any program package, that you have installed, that can cause a conflict with evolution?
    - Did you check that the drive and the file system is healthy? See for example this link.

    - Did you try the suggested command with elevated permissions (sudo)?

    Code:
    sudo apt update
    sudo apt --fix-broken install
    and after that

    Code:
    sudo apt update
    sudo apt full-upgrade
    You may need to repeat this sequence of commands. Please try it and let us know the result.
    Last edited by sudodus; June 10th, 2021 at 09:31 AM. Reason: ninja'd by 2 'faster helpers' ;-)

  5. #5
    Join Date
    May 2021
    Beans
    8

    Re: Error, bug or something else

    First off
    SUDO APT UPDATE

    Code:
    Hit:1 http://au.archive.ubuntu.com/ubuntu focal InRelease
    Get:2 http://au.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]    
    Hit:3 http://dl.google.com/linux/chrome/deb stable InRelease                  
    Get:4 http://au.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]  
    Hit:5 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu focal InRelease      
    Get:6 http://au.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [490 kB]
    Get:7 http://au.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,026 kB]
    Get:8 http://au.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]
    Get:9 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]     
    Hit:10 http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu focal InRelease
    Get:11 http://au.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [781 kB]
    Get:12 http://au.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [330 kB]
    Get:13 http://au.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
    Get:14 http://au.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1,768 B]
    Hit:15 http://ppa.launchpad.net/savoury1/digikam/ubuntu focal InRelease       
    Get:16 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24.5 kB]
    Get:17 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [58.3 kB]
    Get:18 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]
    Fetched 3,327 kB in 2s (1,366 kB/s)                                           
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    14 packages can be upgraded. Run 'apt list --upgradable' to see them.

  6. #6
    Join Date
    May 2021
    Beans
    8

    Re: Error, bug or something else

    Code:
    sudo apt --fix-broken install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      brasero-cdrkit catdoc cdparanoia dvdauthor k3b-data k3b-i18n keditbookmarks kio kpackagelauncherqml kpackagetool5 libepub0 libflac++6v5 libhfstospell10 libiso9660-11 libk3b7 libk3b7-extracodecs
      libkf5archive5 libkf5attica5 libkf5auth5 libkf5bookmarks-data libkf5bookmarks5 libkf5cddb-data libkf5cddb5 libkf5completion-data libkf5completion5 libkf5declarative-data libkf5declarative5
      libkf5doctools5 libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5iconthemes-bin
      libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5 libkf5kiocore5 libkf5kiofilewidgets5
      libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5
      libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5quickaddons5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
      libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libmusicbrainz5cc2v5 libphonon4qt5-4 libphonon4qt5-data libpoppler-qt5-1 libqt5positioning5 libqt5quickcontrols2-5 libqt5quicktemplates2-5
      libqt5quickwidgets5 libqt5sensors5 libqt5test5 libqt5webchannel5 libqt5webkit5 libvcdinfo0 libvoikko1 libzip5 phonon4qt5 phonon4qt5-backend-vlc qml-module-org-kde-kirigami2
      qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-newstuff qml-module-qtqml-models2 qml-module-qtquick-controls2 qml-module-qtquick-templates2 sonnet-plugins vcdimager
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      evolution-common
    The following packages will be upgraded:
      evolution-common
    1 to upgrade, 0 to newly install, 0 to remove and 13 not to upgrade.
    43 not fully installed or removed.
    Need to get 0 B/695 kB of archives.
    After this operation, 73.7 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 235361 files and directories currently installed.)
    Preparing to unpack .../evolution-common_3.36.5-0ubuntu1_all.deb ...
    Unpacking evolution-common (3.36.5-0ubuntu1) over (3.36.4-0ubuntu1) ...
    dpkg: error processing archive /var/cache/apt/archives/evolution-common_3.36.5-0ubuntu1_all.deb (--unpack):
     failed to stat (dereference) existing symlink '/usr/share/help/sl/evolution/mail-encryption-gpg-decrypting.page': Input/output error
    Errors were encountered while processing:
     /var/cache/apt/archives/evolution-common_3.36.5-0ubuntu1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  7. #7
    Join Date
    May 2021
    Beans
    8

    Re: Error, bug or something else

    OK. It's a mail client called Evolution. Forgot about it because I couldn't get it to do what I wanted. Now the problem seems to be I can't get rid of it

  8. #8
    Join Date
    May 2021
    Beans
    8

    Re: Error, bug or something else

    Code:
    [sudo apt remove evolutionReading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     evolution-ews : Depends: evolution (>= 3.36) but it is not going to be installed
                     Depends: evolution (< 3.37) but it is not going to be installed
     evolution-plugin-bogofilter : Depends: evolution (= 3.36.5-0ubuntu1) but it is not going to be installed
     evolution-plugin-pstimport : Depends: evolution (= 3.36.5-0ubuntu1) but it is not going to be installed
     evolution-plugins : Depends: evolution (= 3.36.5-0ubuntu1) but it is not going to be installed
     libevolution : Depends: evolution-common (= 3.36.5-0ubuntu1) but 3.36.4-0ubuntu1 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

    I feel like a Windows user right now. how do I get rid of this? or am I looking at a re-install? BTW. Ubuntu 20.04, and I'm completely new (a few weeks) to Linux
    Last edited by deadflowr; June 10th, 2021 at 04:42 PM. Reason: fixed code tag brackets

  9. #9
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Error, bug or something else

    Did you try also a full-upgrade?

    Code:
    sudo apt full-upgrade
    and repeat the commands. If still problems, did you try

    Code:
    sudo apt update
    sudo apt-get install -f
    sudo apt-get install -m
    sudo apt update
    
    sudo apt remove evolution
    Last edited by sudodus; June 10th, 2021 at 10:04 AM.

  10. #10
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Error, bug or something else

    Maybe some of the non-ubuntu repositories causes the problem:

    Code:
    dl.google.com/linux/chrome/deb
    ppa.launchpad.net/audio-recorder/ppa/ubuntu
    ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu
    ppa.launchpad.net/savoury1/digikam/ubuntu
    but let us hope that you will soon fix it without removing the applications installed from there and those repositories.

    I think there is a snap alternative for Chrome, and it should be less intrusive.

    https://snapcraft.io/install/chromium/ubuntu
    Last edited by sudodus; June 10th, 2021 at 10:14 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •