Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Unable to install libdvd-pkg. Broken packages.

  1. #1
    Join Date
    Apr 2014
    Beans
    793

    Unable to install libdvd-pkg. Broken packages.

    Code:
    $ sudo apt install libdvd-pkg
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     libdvd-pkg : Depends: build-essential but it is not going to be installed
                  Depends: debhelper (>= 9) but it is not going to be installed
                  Depends: dh-autoreconf but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Code:
    $ apt policy libdvd-pkg
    libdvd-pkg:
      Installed: (none)
      Candidate: 1.4.2-1-1
      Version table:
         1.4.2-1-1 500
            500 http://us.archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages
    This is my desktop that is used for Kodi via the offical Kodi ppa, the Makemkv ppa, and pci pass through where I run a Windows VM that I game on. I rip dvd's occasionally via the Makemkv and compress with Handbrake. I wanted to install the above package so I could run vlc on a dvd and be able to tell which title was which in a given dvd.
    Last edited by Tadaen_Sylvermane; June 9th, 2021 at 09:06 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,889
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to install libdvd-pkg. Broken packages.

    Tadaen_Sylvermane; Hummm ...

    Right now is a head scratcher for what is not going on.

    Let's see what we can do to get some additional info.

    Code:
    sudo apt update
    sudo apt upgrade
    sudo apt -f install
    all return clean ?

    See then where we go from here.

    all in the process
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Apr 2014
    Beans
    793

    Re: Unable to install libdvd-pkg. Broken packages.

    Code:
    $ sudo apt update
    Hit:1 http://ppa.launchpad.net/heyarje/makemkv-beta/ubuntu focal InRelease
    Hit:2 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu focal InRelease
    Hit:3 http://us.archive.ubuntu.com/ubuntu focal InRelease
    Hit:4 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease
    Hit:5 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease
    Hit:6 http://us.archive.ubuntu.com/ubuntu focal-security InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
    This is it. If it's not in these repos then I don't have it. No custom compilations.

    Code:
    $ sudo apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    full-upgrade also returns the same result.

    Code:
    $ sudo apt install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Last edited by Tadaen_Sylvermane; June 10th, 2021 at 06:40 PM.

  4. #4
    Join Date
    Jun 2016
    Beans
    2,275
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to install libdvd-pkg. Broken packages.

    Can you please post the output of
    Code:
    apt-get -s install build-essential
    Xubuntu 20.04/Pop!_OS 21.04/System76 hardware ♦ Debian 10/Xubuntu/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  5. #5
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to install libdvd-pkg. Broken packages.

    I wonder if the two launchpad repos you are using
    Code:
    Hit:1 http://ppa.launchpad.net/heyarje/makemkv-beta/ubuntu focal InRelease
    Hit:2 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu focal InRelease
    have introduced different versions of some packages and upset the dependency requirements of something else as those three packages mentioned in your original post are available in the normal repos as versions that are above the minimum versions shown in that post so should be OK for your installation.

    Have you tried installing build-essential, debhelper and dh-autoreconf separately or are they perhaps already installed? If they are not installed already try doing so as a separate action; that may give us more clues in the output you get, so run command
    Code:
    sudo apt install debhelper build-essential dh-autoreconf
    and copy back here the output you get.

  6. #6
    Join Date
    Apr 2014
    Beans
    793

    Re: Unable to install libdvd-pkg. Broken packages.

    Code:
    $ sudo apt-get -s install build-essentialReading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     build-essential : Depends: libc6-dev but it is not going to be installed or
                                libc-dev
                       Depends: g++ (>= 4:9.2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Code:
    $ apt policy libc6-devlibc6-dev:
      Installed: (none)
      Candidate: 2.31-0ubuntu9.2
      Version table:
         2.31-0ubuntu9.2 500
            500 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
         2.31-0ubuntu9 500
            500 http://us.archive.ubuntu.com/ubuntu focal/main amd64 Packages
    Code:
    $ sudo apt install libc6-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    
    The following packages have unmet dependencies:
     libc6-dev : Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.3 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Code:
    $ apt policy libc6libc6:
      Installed: 2.31-0ubuntu9.3
      Candidate: 2.31-0ubuntu9.3
      Version table:
     *** 2.31-0ubuntu9.3 100
            100 /var/lib/dpkg/status
         2.31-0ubuntu9.2 500
            500 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
         2.31-0ubuntu9 500
            500 http://us.archive.ubuntu.com/ubuntu focal/main amd64 Packages
    I did a bunch of chasing with apt policy and trying to install. Ultimately the libc6 seems to be the issue. It is version 9.3 but stuff wants 9.2.

    I tried eliminating both PPA's as well as dumping the packages themselves. No dice.
    Last edited by Tadaen_Sylvermane; June 11th, 2021 at 03:02 AM.

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,889
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to install libdvd-pkg. Broken packages.

    Tadaen_Sylvermane; Yukkie

    Something here is not adding up;
    There is
    apt list libc6 >> libc6/now 2.31-0ubuntu9.3 amd64
    However
    apt show libc6-dev >> Depends: libc6 (= 2.31-0ubuntu9.2)
    Are we looking at a packaging error ?

    south side of right ?
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  8. #8
    Join Date
    Jun 2016
    Beans
    2,275
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to install libdvd-pkg. Broken packages.

    Thanks for the outputs, that shows what's going on. I had to fix this on another computer recently.

    To help us determine the exact terminal command to suggest for you, can you please post the output from running the script from this post?

    (If it gives an error make sure you have python3-apt installed.)
    Last edited by halogen2; June 11th, 2021 at 03:53 AM.
    Xubuntu 20.04/Pop!_OS 21.04/System76 hardware ♦ Debian 10/Xubuntu/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  9. #9
    Join Date
    Apr 2014
    Beans
    793

    Re: Unable to install libdvd-pkg. Broken packages.

    I don't know. This has been out since April of last year? I have doubts I'm the first person to hit it, unless there was an update recently. It's really odd. I am inching toward just putting Windows back on this machine for my games but I like being able to snapshot the file system with LVM. Makes backups 100x easier to deal with and I can just sync them to my server. Done twice a week currently.

  10. #10
    Join Date
    Apr 2014
    Beans
    793

    Re: Unable to install libdvd-pkg. Broken packages.

    Code:
    :~$ ./pyapt.py
    libc-bin        2.31-0ubuntu9.3
    libc6   2.31-0ubuntu9.3
    libc6-dbg       2.31-0ubuntu9.3
    locales 2.31-0ubuntu9.3

    That's what it gave me.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •